Question My desktop and my laptop are connected to the same modem but they can't detect each other.

May 19, 2019
6
0
10
0
I have a CenturyLink Zyel Zyxel C3000Z modem. My desktop and my laptops are all connected to it (via ethernet and wifi respectively). My laptops can communicate with each other, but the desktop cannot, as if being connected by an ethernet cable walls it off into a separate network.

I've tried having the desktop and laptop ping each other, and it doesn't work.

They all have the same IP address and can connect to the internet just fine.

For example: if I start a Minecraft LAN game on a laptop, the other laptop (which is on the same wifi network as the first) can immediately detect it and join. The desktop cannot detect it at all.

Similarly, if I start a Minecraft LAN game on the desktop, the laptops can't see it.

On my previous modem, this was not a problem. The desktop could see LAN games on the laptops.

I need a way to make the modem recognize devices connected via ethernet as part of the same network as wifi devices.
 
Last edited by a moderator:

Lutfij

Titan
Moderator
Are you working with the same OS for all devices connected? When you say modem, Are you on the latest firmware for the router/modem? You might want to log in to GUI for the modem and see if all devices are connected and shown in the network map(on the router/modem).
 

AllanGH

Commendable
Mar 10, 2019
1,752
337
1,640
49
Some modem/gateway/router devices have a setting that isolates the wireless network from the wired network. Login to your modems administration interface and examine settings to see if this is the case with your hardware.
 
May 19, 2019
6
0
10
0
Are you working with the same OS for all devices connected? When you say modem, Are you on the latest firmware for the router/modem? You might want to log in to GUI for the modem and see if all devices are connected and shown in the network map(on the router/modem).
Yes, all computers are using the same OS, Windows 10.

All firmware is updated.

All devices are connected to the modem/router.
 
May 19, 2019
6
0
10
0
Some modem/gateway/router devices have a setting that isolates the wireless network from the wired network. Login to your modems administration interface and examine settings to see if this is the case with your hardware.
I can't see any settings in the modem's GUI that explicitly isolate the wireless and wired networks. But if it's in technical jargon I may have missed it.
 
What u describe then is impossible, something is not configured correctly.

If both machines are on the same subnet and they can't ping each other, that violates how tcp/ip works, I mean you the user would have to had intentionally disable icmp. Pinging is a basic networking mechanism, it needs no permission and enabled by default.

UNLESS the box both machines are hooked up have FILTERS enabled and you are not disclosing.
 
May 19, 2019
6
0
10
0
What u describe then is impossible, something is not configured correctly.

If both machines are on the same subnet and they can't ping each other, that violates how tcp/ip works, I mean you the user would have to had intentionally disable icmp. Pinging is a basic networking mechanism, it needs no permission and enabled by default.

UNLESS the box both machines are hooked up have FILTERS enabled and you are not disclosing.
How would I find out if the modem/router has filters enabled? The only theory I've got is that it's keeping the wired and wireless networks separate, but I can't find a button in the device's setting to undo that.
 

Ralston18

Titan
Moderator
This:

"They all have the same IP address and can connect to the internet just fine."

How was that determined or were the network adapters configured identically....?

Run "ipconfig /all" via the command prompt on the desktop and each laptop.

None of the devices should have the same IP address: dynamic or static.
 
May 19, 2019
6
0
10
0
This:

"They all have the same IP address and can connect to the internet just fine."

How was that determined or were the network adapters configured identically....?

Run "ipconfig /all" via the command prompt on the desktop and each laptop.

None of the devices should have the same IP address: dynamic or static.
Ah, I was looking at the devices' public IP addresses.

They have different IPv4 addresses. Is that what you mean?
 

Ralston18

Titan
Moderator
Yes. Each device should have its own private IPv4 address.

Either DHCP assigned or Statically configured and reserved via the devices MAC.

Only one device (modem/router or router) should be providing DHCP IP addresses within a configurable range of permitted DHCP IP addresses.

Static IPv4 addresses should be outside of that DHCP IP address range.

The router may also be configured to limit the number of devices that can be connected statically or dynamically at any given time.

"Tutorial" to provide some background:

https://stevessmarthomeguide.com/internal-external-ip-addresses/

You can easily find other similar articles and explanations.
 
May 6, 2019
10
0
10
0
My laptop (win10) could not see my desktop until I googled for help and it was recommended to go to 'Programs and Features' and in Windows features to turn on 'Simple TCPIP Services' and enable the SMB protocol.
 

digitalgriffin

Distinguished
Jan 29, 2008
421
63
18,870
3
My laptop (win10) could not see my desktop until I googled for help and it was recommended to go to 'Programs and Features' and in Windows features to turn on 'Simple TCPIP Services' and enable the SMB protocol.
Smb is for file access. And smb version 1 will make you vulnerable to the exploit.

If you dont know which smb version shut it down now!

 
May 6, 2019
10
0
10
0
Smb is for file access. And smb version 1 will make you vulnerable to the exploit.

If you dont know which smb version shut it down now!

I don't think so - I now have access and need it.

remember > The thing you most need to fear is fear itself.

I image all my drives for safety - the ultimate protection
 
May 24, 2019
8
1
15
0
I've had pretty similar problems before. One solution was for me to go into the "Network" tab in Windows-Explorer and then enabling the Network-Discovery which is disabled by default.

This can be done in the Control Panel > Network and Internet > Network and Sharing Center > Advanced sharing settings.
 

ASK THE COMMUNITY