Question My External HDD Won't Let Me Access Some Files

longjohnjayson

Prominent
Nov 30, 2017
2
0
510
0
I've been having this issue for quite a while. I've fresh installed windows onto my PC multiple times and every time any pictures or videos i want to save i transfer to my external. I have 2 different ones I have a WD My Book 1140 2tb and a Seagate Expansion 5TB(STEB5000100). On my seagate any picture from my transfers are locked and i don't have permission to view them. but all the videos i transferred such as movies or music i have full access to. As for the My Book, I have access to all my multiple transfers except for one of the folders. I did a comparison between each folder and the only difference was that the one i couldn't access had faded out permissions and inheritance enabled. I've since gotten rid of the inheritance so the permission are no longer faded but i still get locked out of these specific files. Now there is no difference in the files anywhere in the security tabs but still i can't get permission to view them. I've followed this guide completely "https://answers.microsoft.com/en-us/windows/forum/all/accessing-old-drive-from-new-drive-os-security/6ae783c5-1256-4659-abe8-d24b665b4a7d". I've even tried using regedit to give me an option to take access when i right click and it still wont take access.

After just checking through both drives, I even have the same folders in both, with access to it in one but not the other.

When trying to change file ownership to personal I get an invalid MS-DOS function error.

Right clicking a photo and going to properties to advanced attributes. Encrypt contents to secure data is check marked and grayed out, clicking on details shows an old windows account name and certificate thumbprint, not sure if this is the reason im not allowed access.
 

LiquidEternity

Commendable
Jan 2, 2017
130
2
1,765
39
i didnt read everything you wrote but (sorry little tired)

sounds like one of your hard drives has permissions on it from your previous windows, now with the fresh windows - those users (doesn't matter same name, think SID) are no longer on the PC/permission error occurs.

few things you can do and one thing to solidly prevent in the future;

https://www.howtogeek.com/howto/windows-vista/add-take-ownership-to-explorer-right-click-menu-in-vista/

use take ownership, the above link is a quick way to just get the job done "sledge hammer approach" - some times its needed

if that doesn't work let me know and i'll give you some more info

--

to prevent in the future, use a "backup" software - i use quotes because there is a difference between syncing files and sector backup. This is more just syncing files - good enough for your average user. Good sync is what I recommend, uncheck in the settings (use google) the ACL and NTFS permissions copy, this will STOP the current permissions being copied (what I think your issue here is), but rather set the permissions as default, so basically creator owner/system/admin etc. Then you can move on
 
The above solution may work for you which is great, but I am just going to say if you need to backup something, if you trust the cloud, (I do). I store backups of my photos online, because even someone here had backups and they had a fire and lost everything.
So although its great to back up things onto other hard drives, it's also great to have a cloud storage backup as well.
I use dropbox (which I pay for) and google drive
 

Phillip Corcoran

Titan
Moderator
When backing up your data it's best to create your own folders first on the backup drive, then copy/paste just the files to the backup drive in to those new folders.
Backing up that way avoids any permissions issues when you later need to access those backup files using a different Windows account.
 

ASK THE COMMUNITY