Question My external SSD stopped working suddenly, not showing anywhere in Windows ?

jacklevics

Prominent
Apr 5, 2020
3
0
510
0
Hi,
I've got a 1GB Seagate Expansion portable SSD. I have used it for over a year with this laptop and It was working fine until last night on my MSI GE62VR Apache Pro laptop.

I was downloading something on the Microsoft Store to the external drive last night. I was at the same time trying to fix another problem on my laptop that bluetooth completely disappeared on it.
To try and resolve that bluetooth problem I was trying lots of things. Trying to reset and start bluetooth in services. Trying to install drivers again.
I downloaded Intel Driver and Support Assistant. It came up with 4 things it downloaded and installed. Apologies I can't remember all of them.
In the end I somehow got bluetooth working again but then realised my drive wasn't showing anymore.

It shows nowhere on the system. Not showing in device manager. Not showing in disk management, so cannot create partition. But I can see it showing in BIOS only.

The drive still lights up on the LED and when I connect it via USB windows knows I've plugged something in because it makes the sound and same when I disconnect. But no alerts show in windows

I've looked and tried at many things to get it working.
The external drive works fine in other systems. And other external storage devices are read fine by my MSI laptop.

Also the drive does not show in Intel Rapid Storage Technology App

  • I've tried uninstalling all the USB controllers in device manager and reinstalling on reboot.
  • Tried all USB ports and tried new SATA cable
  • I've ran Windows Memory Diagnostic.
  • Tried uninstalling and reinstalling on boot the AHCI controller in device manager.
  • Tried changing BIOS to RAID and then back to AHCI. Think I tried turning off quick boot.
  • Reinstalled Windows 10
  • Tried formatting the drive on other computer and then trying on the MSI
Still will not work at all on this computer, yet everything else I use with this computer is fine.

Does anybody have any other suggestions because I am so confused now ?

Many many thanks!

Jack
----------------------------------------------------------------------------------------
Processor Intel(R) Core(TM) i7-6700HQ CPU @ 2.60GHz 2.60 GHz
Installed RAM 16.0 GB (15.9 GB usable)
Windows 10 Home Edition
System type 64-bit operating system, x64-based processor
 
Last edited:
check what software Seagate offers for controlling this device.
it's possible they also have specific drivers for this drive available.
Tried all USB ports and tried new SATA cable
what SATA cable?
if this is an external USB drive there should be no SATA cable involved.

is this just a drive housing that you have added your own drive to?
or have you disassembled the Expansion's housing?
 

ASK THE COMMUNITY