MY GAME ISN'T WORKING!!!! help

minibot7

Distinguished
Sep 11, 2009
40
0
18,530
I bought a geforce 8400gs with 512mb ,and my game just crash after some problems. It seems like the words which you can click on(stuff like options, find servers) become really mess up, you can't read it anymore, it's just full of squares and rectangles with different colors, then in a few secs my computer just stuck and I have to restart computer. And whenever I watch a video in full screen the video seems to be really slow, l don't mean the buffering but the image, and sometimes even gets stuck.

This is a image(http://2.bp.blogspot.com/_iHiMZpT6hDk/SqsCQk0ux9I/AAAAAAAAAAU/a-UGpgLftfE/s1600-h/tf2+problem.bmp)
 

minibot7

Distinguished
Sep 11, 2009
40
0
18,530

any suggestions for graphic card I should get? I got pci slot and agp, I had an ATI Radeon 9550, but I can't play any games with that, it always overheat.
 

scudst0rm

Distinguished
Feb 17, 2008
157
0
18,710
8400 GS should be able to run TF2, not well mind you, you'll have to crank down all the settings, but still playable.

As for the texture/icon problem in the pic you posted, I used to get that every now and then on my old PC with an 8800GT, It couldn't have been an overheating problem cuz I had the zalman cooler version and It would run about 40C.

What are the rest of your system specs? what power supply do you have (wattage, brand, age)?
 

minibot7

Distinguished
Sep 11, 2009
40
0
18,530

my computer is an acer, got it 2-3 years ago, or maybe later than that. AMD Sempron processer 3300+ 2.01 GHz , 1.18 of RAM, and how do I check for my power supply??