Question My Gigabyte B450 Gaming v.1 Motherboard won't enter POST.

Sep 5, 2019
2
0
10
0
So I got a Gigabyte B450 Gaming v.1 paired with a Ryzen 5 3600 CPU, I know they're not compatible and you need to update the BIOS. When I got it I built my PC I went into the BIOS and I forgot to check if my memory, hdd etc is running correctly as I was too eager to update my BIOS. I first updated my BIOS to f32 as recommended before updateting to f40. I updated my BIOS it said BIOS update completed your system will restart, and it did. After it restarted there was just a black screen for about 20 seconds, since the motherboard doesn't support the 3600 without the f40 BIOS update i thought nothing would show up so I just restarted my PC after that 20 seconds. When I turned my PC back on and started pressing the delete key nothing was happening so I restarted and tried again, nothing. At this point I thought I corrupted my BIOS so I tried clearing my CMOS my jumping the clr_cmos pins, I tried removing the battery, nothing just black screen and when I try entering BIOS nothing happens. I have also rebuilt my entire system multiple times to check if it was maybe the connections, still no luck. Ive tried to build it outside of my case, no luck. Ive tried to keep in only my RAM and boot the Motherboard, no beeps. Ive made sure multiple times all of my connections are in all the way and sturdy. My CPU fan, case fan, GPU are all on, the red LED on my motherboard is on too but again, just black screen with no BIOS. When I power on my system, wait a little and hold my power button the red LED on the motherboard starts flashing and so does the power button.

My specs are:

CPU: Amd Ryzen 5 3600
Motherboard: Gigabyte B450 Gaming
Memory:Corsair Vengeance LPX DDR4-3000
Storage: Western Digital Caviar Blue 1TB
GPU: RX590 8 GB FATBOY OC+
Case: Corsair SPEC-DELTA RGB
PSU: Corsair CXM 550 W 80+ ATX

Please help me!! :rolleyes:
 

ASK THE COMMUNITY

TRENDING THREADS