Question my Gigabyte Rx570 4gb suddenly no signal then fans super loud , vga debug light is on ..help!!!

Jan 26, 2020
21
0
10
0
i have ryzen 3 1200
mobo - msi A320m pro vd/s v2
ram - adata 4gb ddr4 2666mhz
PSU- 500watts True rated
Gpu - Giagabyte RX570
my problem is after few minutes after boot my GPU no Signal then Fans spins louder ,but rgb of GPU's on , mouse and keybord working , VGA light is on ... is my GPU faulty? i also put the RX570 on athlon 5350 , still boot just few minutes then no signal ,fans spins loud ..
 
Jan 26, 2020
21
0
10
0
Try a better PSU from a name brand. This can be a PSU issue.

this is newly Bought PSU , the name is Absolute Formula pc power supply
model name : F5000
ATX : 500watts
its a little bit heavy
 

DSzymborski

Champion
Moderator
Hard to say with the junk power supply -- and it is junk, plus it was probably manufactured more than a decade ago (and designed even earlier since the outputs are clearly configured for an ATX revision before 2007). Get something proper in there and cross your fingers that the garbagey PSU was the cause of the issue and that it didn't damage the GPU too.
 
Reactions: gleamrey
Jan 26, 2020
21
0
10
0
Hard to say with the junk power supply -- and it is junk, plus it was probably manufactured more than a decade ago (and designed even earlier since the outputs are clearly configured for an ATX revision before 2007). Get something proper in there and cross your fingers that the garbagey PSU was the cause of the issue and that it didn't damage the GPU too.
ANTEC NE550C 550W (80+ BRONZE)
is this Okay? or any Recommendations , Budget PSU if possible
 
Jan 26, 2020
21
0
10
0
Hard to say with the junk power supply -- and it is junk, plus it was probably manufactured more than a decade ago (and designed even earlier since the outputs are clearly configured for an ATX revision before 2007). Get something proper in there and cross your fingers that the garbagey PSU was the cause of the issue and that it didn't damage the GPU too.
FSP Hyper K 85% Efficiency APFC 500watss Power Supply
 

NightHawkRMX

Illustrious
Its around 35 in dollars , this is used PSU sale in online shop , is this a Good deal?
Not a good deal for a used PSU. Its only worth about that new.

PCPartPicker Part List

Type|Item|Price
:----|:----|:----
Power Supply | Corsair CX (2017) 550 W 80+ Bronze Certified ATX Power Supply | $39.99 @ Newegg
| Prices include shipping, taxes, rebates, and discounts |
| Total (before mail-in rebates) | $59.99
| Mail-in rebates | -$20.00
| Total | $39.99
| Generated by PCPartPicker 2020-01-27 06:35 EST-0500 |
 
Jan 26, 2020
21
0
10
0
Not a good deal for a used PSU. Its only worth about that new.

PCPartPicker Part List

Type|Item|Price
:----|:----|:----
Power Supply | Corsair CX (2017) 550 W 80+ Bronze Certified ATX Power Supply | $39.99 @ Newegg
| Prices include shipping, taxes, rebates, and discounts |
| Total (before mail-in rebates) | $59.99
| Mail-in rebates | -$20.00
| Total | $39.99
| Generated by PCPartPicker 2020-01-27 06:35 EST-0500 |
its on sale , Thank you i Will try to grab that .. <3
by the way i just notice , my motherboard is MSI A320M PRO VD/S v2 and my processor is RYzen 3 1200 , i look at my mobo compatability of CPU and Ryzen 3 1200 is not supported , it only support on A320M PRO VD/S but not on version 2 ..
 

DSzymborski

Champion
Moderator
Yeah, I'm not sure why you would need to order two PSUs. If the Corsair doesn't do the trick -- you needed a new PSU anyway -- then something else is going on. It's hard to isolate problems until you remove low-quality PSUs from the equation. That's another of the problems of low-quality PSUs; even if the computer runs without blowing up, the first time there's a tricky problem, you end up having to replace the PSU anyway to diagnose the PC.
 

ASK THE COMMUNITY

TRENDING THREADS