Question My GPU is acting weird

Dec 15, 2020
5
0
10
0
Hi! I recently got my hands on a used Titan X Pascal from a guy who just got a 3080. I purchased it because I was getting a little sick of waiting for my 3080 and figured it'd be a nice upgrade from my 1070 for the price whilst I wait. The card works very well, except for the fact that it's being underutilized in a weird way.
For example, if I set the settings up to the max in Cyberpunk 2077, the card hovers around 98% usage, with me getting between 45-60fps. But since I'm aiming for a smooth 60fps at least, I figure I'll turn the settings down. This, for some strange reason though, doesn't lead to a better framerate but just lower GPU utilization. Sometimes the framerate might even go lower than before. Even if I turn everything down to the minimum and set the resolution scale to the lowest possible option, it's the same situation.
I put together a little video showcasing it. There are no accurate benchmarks, but I think it shows off what I'm saying pretty nicely.
View: https://www.youtube.com/watch?v=Vm-_Z7sp2Z4

It's got me showing the problem off in Cyberpunk, Battlefield 1, and Minecraft (with shaders). Strangely, the issue didn't actually present itself in Minecraft (in the way it usually does) when I tried recording it, even though it happens in there usually too. The GPU was still underutilized, however. That makes sense when I'm not using shaders because at only like 30-50% usage it's getting me framerates in the 200-500 range, but it's weird when shaders are on and I'm only getting 60fps.
To me, it almost seems like the games are trying to hit a certain framerate as if there's a limit on, but in Minecraft and Cyberpunk, there is no limit, and in BF1 the limit is at 200fps, even though the game only stays at around 90-120fps.
 
Dec 15, 2020
5
0
10
0
Full system specs? Please include make and model of the PSU
GPU - GTX Titan X (Pascal)
CPU - Ryzen 7 3700x
RAM - 16gb of DDR4 at 2933MHz
PSU - Corsair CX750M 750w
- Storage -
Crucial MX100 256GB (boot drive)
Samsung 860 EVO M.2 2TB (where i put my games)
WD Black 1TB HDD (for random stuff)
 
The fact that lowering settings did not improve performance is a very clear sign of cpu bottleneck. BUT... A 3700X is not a weak CPU so it must be something that LOOKS like a cpu bottleneck.
Try using DDU in safe mode to remove and reinstall your GPU drivers.

Do you have latest windows updates? BIOS? Chipset drivers from AMD and not from motherboard's manufacturer?

How are your temps of CPU and GPU idle and while gaming?

Run a userbenchmark and post the link to the results. I don't trust it as a benchmark but can help identify an issue.
 
It does seem that the pc has some issue. When. You run the userbenchmark, your background CPU utilisation was a bit higher than expected.bmake sure nothing else runs in the background. Do a malware scan as well.
 
Dec 15, 2020
5
0
10
0
Please check that your RAM is in the correct slots 2 and 4, counting from the side the CPU is located (left to right).

Also, please do what I suggested above and tell me if you see any difference.

Another issue I can see that is performance related, is the relatively low speed of RAM. Ryzen CPUs love fast RAM with best being 3600MHz and very good at 3200MHz.
View: https://www.youtube.com/watch?v=S0WZNwb_6XU
Well I doubt it's the RAM someone on reddit told me my CPU temps looked a bit high, and well, they are. The RAM would probably help, but right now, the CPU gets too hot running Cinebench causing it to literally crash the PC. Gonna get myself a new cooler that isn't the stock one I've got right now, but thanks for the help!
 
Well I doubt it's the RAM someone on reddit told me my CPU temps looked a bit high, and well, they are. The RAM would probably help, but right now, the CPU gets too hot running Cinebench causing it to literally crash the PC. Gonna get myself a new cooler that isn't the stock one I've got right now, but thanks for the help!
In my first answer to you, I asked you about the temps, among other things, but you never answered. Since you came and wrote your question here, mind sharing that information as well so if someone has the same problem can see how you progressed with the issue?
 

ASK THE COMMUNITY

TRENDING THREADS