My GPU is locked at a low clock speed.

Sooley

Commendable
Aug 17, 2016
15
0
1,510
0
Hey all,

Recently, I saw that my games were running at a lower FPS than usual, which was weird because I hadn't changed any settings, and seemed to be completely out of the blue. I opened afterburner and realised my GPU (AMD R7 370) was at a clock speed of 925 MHz, which is 105MHz below factory clock speeds. I hadn't been overclocking or anything, and I make sure my temps never go above 70, so I thought that installing new drivers would probably fix my problem, and now that I have installed them, instead of being stuck at 925 MHz, both my core clock speed and memory clock speed are stuck at 150MHz. I have no idea what caused it in the first place, and nothing I try seems to fix anything. So now instead of games running at 50 FPS instead of 70, they run at around 5-8 FPS.

I am currently trying to roll back to some old drivers and see if they make a difference, so I wanted to ask you guys in case there is an obvious solution.

Thanks!


My specs:

AMD R7 370
AMD FX-8350 @ stock speed
8GB RAM
Gigabyte GA-970A-UD3P Motherboard
ADATA 120Gb SSD
Barracuda 1Tb HDD
 

Scott Wayne

Honorable
Mar 11, 2015
74
1
10,545
3


do not use afterburner get rid of it go to your ati manager and agree to the terms on the globel settings on gaming now you can enable overclocking msi cant do it but u can use it after you enable overclocking but why?ati manager lets you do the same its under clocked for safty reasons and to save power make sure u have good airflow when u overclock remember it will not run full speed unless you are playing a game the r series are realy poorly made do not expect much from them.the rx series would been a better choice.be careful over locking a r series they are not as fast as they are advertised.
 

Sooley

Commendable
Aug 17, 2016
15
0
1,510
0
Well I tried 2 different versions of drivers, and the second one worked, although Afterburner is acting weird and not showing my GPU settings, but it works at least.
 

Scott Wayne

Honorable
Mar 11, 2015
74
1
10,545
3


do not use afterburner get rid of it go to your ati manager and agree to the terms on the globel settings on gaming now you can enable overclocking msi cant do it but u can use it after you enable overclocking but why?ati manager lets you do the same its under clocked for safty reasons and to save power make sure u have good airflow when u overclock remember it will not run full speed unless you are playing a game the r series are realy poorly made do not expect much from them.the rx series would been a better choice.be careful over locking a r series they are not as fast as they are advertised.
 

ASK THE COMMUNITY

TRENDING THREADS