Question My gpu isnt putting out the fps that is should

Jul 11, 2019
13
0
10
0
Okay so I recently started getting into pc gaming and built my first gaming pc. And I've noticed that when I play fortnite I get about 150 fps in game but it drops down to the 100-120s alot. I have all settings on low. I use an Rx590 with a ryzen 7 2700x and 16gb of ddr4 so with all settings on low I should be getting 200 fps as my minimum and like 300 as my max so why does it drop so low all the time? I got used to 144 fps on my monitor so it just always feels so sluggish to me now. Any suggestions as to why my fps is so low? For reference I've seen people with and rx590 and a ryzen 5 2600x get a steady 130 fps on all settings high. My cpu is better yet my fps on all low settings is the same as theirs on all high. I play on 1920 by 1080 with a 144 hz monitor. And my msi after burner says that I am using up to 98% of my GPU in game. If it's doing this to fortnite does it mean it's also doing it to my other games as well?
 

Phaaze88

Reputable
Herald
Your cpu isn't 'better' than a 2600x. It's a 2600x with 2 extra cores and 4 extra threads. 2700x is only better than 2600x in apps that use those extra resources.

All motherboard drivers are installed? Gpu drivers?
What is the speed of the ram, and how many sticks?
 
Reactions: Metal Messiah.
Jul 11, 2019
13
0
10
0
Your cpu isn't 'better' than a 2600x. It's a 2600x with 2 extra cores and 4 extra threads. 2700x is only better than 2600x in apps that use those extra resources.

All motherboard drivers are installed? Gpu drivers?
What is the speed of the ram, and how many sticks?
I have 16 gb of ddr4 (2 sticks of 8gb) 3000mhz and yes, I check for updates everyday manually and also have them set to automatically update as well.
 
Jul 11, 2019
13
0
10
0
That's really weird. Try Fortnite on high and see how it goes. While at that, record the temps and fps. Also the usage too
On low settings game:
-Gpu temp stayed consistent 58c. usage varied from 40%- 87%
-cpu temp stayed a consistent 58c. usage was about 20%-30%
-fps was all over the place. If im just standing still or nothing going on ill hover around the 160 range but once I get into a fight it goes down to 140 then if there is a lot of building which happens a lot it goes down to 120 and then if someone else joins in which happens a lot my fps gets weird and jumps all over the place. Starts jumping between 80 and 120.

On high settings game:
-Gpu temps stayed a consistent 67c. usage was 95-99%
-Cpu temp stayed a consistent 57c.usage was about 20-30%
-Fps was 90 to 100 just standing still or nothing going on once I got into a fight it would drop to 68 and then go up and steady around 85
 
Jul 11, 2019
13
0
10
0
Looks good, save for one thing - the ram.
You just need to enable XMP in the bios. The speed ram is rated for is not out of the box. It's been running at the default 2133 all this time.
Once you've done that, give your games another go. The fps should be more stable.
alright, ill turn it on and see how it goes
 

ASK THE COMMUNITY

TRENDING THREADS