[SOLVED] My graphics card doesn't detect it's on a PCI-E 3.0

Aug 12, 2019
67
8
45
2
Good morning everyone.

I have been getting problems with my computer, specially the gpu. After some research, i found out that my GPU is using PCI-E 2.0 16x @ 4x 2.0 and i actually did put it on the PCI-E slot that is 3.0 (at least that's what is drawn on the motherboard).

If you wonder what i tried for the GPU to try to fix the performance, i tried the following:

  • Clean driver install using DDU
  • Tweaking a lot of settings in the Nvidia CPanel
  • Rolling back to older drivers
  • Formatting windows
  • Disabling HPET
  • Disabling some services that should not be running
  • Stress testing it several times with many overclock configurations (the difference in performance it seems minimum, like 1-2%)
My current setup is:

CPU: Ryzen 5 2600
GPU: MSI GTX 1660 Ti Gaming X
MOBO: Asrock AB350m Pro4
PSU: Nox Urano 650w 80+ bronze

If you wonder, the psu provides enough watts to keep my computer working well. It should need minimum 344w and it's recommended to have around 450 (which is what this psu can draw).

My question is, is there any way to make the GPU use the PCI-E 3.0 x16 @ x16 3.0? If i have to change it manually i will, but i think the culpirit is that it's using PCI-E 2.0 x16 @ x4 2.0.

Thank you in advance
 

ASK THE COMMUNITY

TRENDING THREADS