Question My Graphics Card seems to turn off after exiting a game.

Aug 21, 2020
3
1
15
0
So I recently just built a new PC (specs below) and everything was running very smoothly for about 2 weeks. This morning however I was trying to play CSGO and my frames were capped to around 60fps and when trying to play COD MW Warzone they were capped at around 30 fps. I noticed that the lights on my gpu weren't working, but when checking if the GPU was still working my PC says it is good and I can turn the lights back on and get the fans to cool it down etc.

V-sync is disabled, I made sure there is no frame cap, my CPU and GPU temps are good, drivers are up to date. Everything I can think of I've checked. No matter what I do to in-game settings it doesn't make a difference.

The only thing that seems to work is uninstalling the GPU and restarting my computer (re-installing the GPU). When I do that and then go into a game it is back to normal; normal frames and running very smoothly. This is when the lights turn off on the GPU and if I alt-tab or exit the game and go back in, it goes straight to the 60fps cap again. I've made sure the power cables and plugged in correctly and everything so no idea what it could be. Any help would be appreciated.

PC Specs:
Motherboard: MSI MPG Z490 GAMING EDGE WIFI
CPU: Intel Core i7-10700
CPU cooler: Fractal Design Celsius S36 Blackout
GPU: NVIDIA GeForce GTX 1660 Super
RAM: CORSAIR Vengeance RGB Pro 16GB (2 x 8GB)
 
Aug 21, 2020
3
1
15
0
Do you mean the graphic drivers, or do you mean open the case and physically remove the gpu from the motherboard and then re-seat it back again?
Going into device manager and uninstalling the device. I've tried reinstalling the drivers and that didn't help.
 
Aug 21, 2020
3
1
15
0
Then try to install an older version of the driver to see if that helps.
So I installed the driver before the current one and the lights did not turn off on the graphics card when I went into a game. However there was a slight frame drop again. I also turned off Gaming Mode in Dragon center as that was changing things and that seemed to do the job. Not sure if it was one or the other, but thank you for the help!
 
Reactions: Grobe

johnsoner13

Upstanding
Nov 24, 2019
332
52
290
16
So I installed the driver before the current one and the lights did not turn off on the graphics card when I went into a game. However there was a slight frame drop again. I also turned off Gaming Mode in Dragon center as that was changing things and that seemed to do the job. Not sure if it was one or the other, but thank you for the help!
It was 100% dragon center. Uninstall it, it’s pure trash and causes more harm than good
 

ASK THE COMMUNITY