Question My graphics card was artifacting

May 21, 2019
29
1
35
0
My specs are as follows

CPU

Intel - Core i7-8700K 3.7 GHz 6-Core Processor
CPU Cooler

be quiet! - Dark Rock 4 CPU Cooler
Motherboard
Asus - ROG STRIX B360-I GAMING Mini ITX LGA1151 Motherboard
Memory

Corsair - Vengeance LPX 16 GB (2 x 8 GB) DDR4-3000 Memory
Storage

Intel - 660p Series 1 TB M.2-2280 Solid State Drive $104.89
Video Card

Gigabyte - GeForce RTX 2070 8 GB WINDFORCE Video Card
Case

NZXT - H500 ATX Mid Tower Case
Power Supply

Corsair - TXM Gold 550 W 80+ Gold Certified Semi-modular ATX Power Supply

OS windows 10

This is a follow up thread by my brand new graphics card recently randomly stopped working after two weeks and starting crashing my PC, I monitored my temps very closely and made sure all of my cords were correctly plugged in, I took the GPU out and used the integrated graphics from the motherboard and everything worked fine, Im just wondering what my next steps should be.

Since I dont have access to another PC where would I go to test the card?

Or should I send it in and have NVIDIA look at it?
 

ElectrO_90

Dignified
BANNED
Your equipment is all good quality, so this leaves 2 things.
  1. another faulty GPU - which can happen
  2. motherboard is sending some weird voltages into the GPU through the pci-e
If it happens a 3rd time, then I would suggest it isn't the GPU anymore. But send it back while you still can

You can Underclock it and see if the artefacts go, then you know it's probably a memory problem.
 
May 21, 2019
29
1
35
0
Your equipment is all good quality, so this leaves 2 things.
  1. another faulty GPU - which can happen
  2. motherboard is sending some weird voltages into the GPU through the pci-e
If it happens a 3rd time, then I would suggest it isn't the GPU anymore. But send it back while you still can

You can Underclock it and see if the artefacts go, then you know it's probably a memory problem.
Yea is this a common issue though? I was just concerned since it was working so well for two weeks and then out of nowhere this happened, I have examined everything about my build and I thought maybe the mini motherboard could have been a problem but I have heard nothing but good things about it.
 
May 21, 2019
29
1
35
0
Yea is this a common issue though? I was just concerned since it was working so well for two weeks and then out of nowhere this happened, I have examined everything about my build and I thought maybe the mini motherboard could have been a problem but I have heard nothing but good things about it.
If its a memory problem a new ssd would fix it then?
 

ElectrO_90

Dignified
BANNED
If its a memory problem a new ssd would fix it then?
Memory on the GPU, normally when that goes faulty you get artefacts, but you can correct it sometimes by lowering the speed of the memory in the GPU
But since it's brand new, you can try this but return it anyway, even if that cures it. To which, if it does, you can return it and tell them it works if memory is clocked lower.
 
May 21, 2019
29
1
35
0
Memory on the GPU, normally when that goes faulty you get artefacts, but you can correct it sometimes by lowering the speed of the memory in the GPU
But since it's brand new, you can try this but return it anyway, even if that cures it. To which, if it does, you can return it and tell them it works if memory is clocked lower.
I returned it, Im just worried about something else being wrong since this happened so quickly, is a faulty GPU a common problem?
 
May 21, 2019
29
1
35
0
It happens; for me in the last 25 years, I have only had 1 faulty one that I recall
Yea its my first build so it seems like im either super unlucky or something is wrong, but it working so well for two weeks then all of sudden artifacting is what makes minimal sense especially since I didnt run any graphically intense games and temps were never reaching high numbers
 

ASK THE COMMUNITY

TRENDING THREADS