Question My headset stop working after downloading latest realtek audio driver from my motherboard

Bradfishh

Prominent
Nov 26, 2019
4
0
510
0
My audio works fine with the default windows drivers but once i download the realtek driver it doesn't give me any audio, when I try testing the audio in the sound playback setting it says it failed to play test tone.
 
That's the driver i downloaded, I have an ASUS ROG MAXIMUS XI HERO.
Failed to play sound test tone error message can appear if your audio device isn't set as default device. To fix this problem, you need to do the following: Open the Sound window. You can do that by right clicking the sound icon in the bottom right corner and choosing Playback devices.

Make sure the good playback device is being used. Sometime after installing audio drivers the playback device switch to something else. Like here I have speaker on my monitor and when I installed the audio drivers it was set for the monitor and there was no sound in my headset. Had to change the audio source realtek audio.
 

Bradfishh

Prominent
Nov 26, 2019
4
0
510
0
Failed to play sound test tone error message can appear if your audio device isn't set as default device. To fix this problem, you need to do the following: Open the Sound window. You can do that by right clicking the sound icon in the bottom right corner and choosing Playback devices.

Make sure the good playback device is being used. Sometime after installing audio drivers the playback device switch to something else. Like here I have speaker on my monitor and when I installed the audio drivers it was set for the monitor and there was no sound in my headset. Had to change the audio source realtek audio.
I have 2 options, Speakers and realtek digital output. I have tried setting both of them to the default device but still nothing. and the test still fails. On top of that when i try to play a song on spotify now, it just keeps skipping songs until the program stops responding.
 

ASK THE COMMUNITY