Question My keyboard is delayed in games, its fine on everything else tho, being on Google and typing something is pretty much instant.

May 8, 2019
18
1
15
0
Laptops can struggle to cope when gaming as it's a very resource-hungry process, that could account for the keyboard input delay.
Is it built for gaming? (make & model, and full specs).
It's not a gaming rig or anything, but it's still quite decent. I didn't have this problem a while ago.
AMD A9-9420 RADEON R5, COMPUTE CORES 2C + 3G 3.00.GHZ 4 GB ram
 
May 8, 2019
18
1
15
0
Possible fix - - see the last post in this thread:
what was the fix? it didnt seem like the guy fixed his delay
 

Phillip Corcoran

Titan
Moderator
On the contrary, in the last post the guy said what he did definitely did fix the keyboard input lag:

"I had the problem and fixed it easily, it might not work in all cases but worked for me.

I only had to change the input language to English US from English UK, by right clicking the icon that was for some reason on the right of the task bar.

I looked into it further and there seems to be a language bug.

for me when i changed the input language the lag on the keyboard was gone while playing games, but the Keyboard layout was wrong for some keys like the @ symbol had switched with the " symbol as expected.

However when i rebooted the ENG (language icon on right of task bar) was gone and the settings were english uk again and the lag was still gone".
 
May 8, 2019
18
1
15
0
On the contrary, in the last post the guy said what he did definitely did fix the keyboard input lag:

"I had the problem and fixed it easily, it might not work in all cases but worked for me.

I only had to change the input language to English US from English UK, by right clicking the icon that was for some reason on the right of the task bar.

I looked into it further and there seems to be a language bug.

for me when i changed the input language the lag on the keyboard was gone while playing games, but the Keyboard layout was wrong for some keys like the @ symbol had switched with the " symbol as expected.

However when i rebooted the ENG (language icon on right of task bar) was gone and the settings were english uk again and the lag was still gone".
didnt fix it
 

ASK THE COMMUNITY

TRENDING THREADS