My laptop won't connect to the WiFi.

S_Sutton

Reputable
Mar 8, 2014
1
0
4,510
0
I have a Lenovo Ideapad with Windows 8 and I'm away for the weekend. I connected to the WiFi and it worked fine last night, but now it says it can't connect and the other people with me can connect. I have the password correct so I can't figure out what's wrong. I tried rebooting it. It didn't work.
 

Markkk

Distinguished
Jan 2, 2012
447
0
18,960
74
OR renew your IP address...

1. Open windows command prompt Start\ Run\cmd\ok

2. To release your Ip address ipconfig/release
Enter

3. To renew your IP address ipconfig/renew
Enter

Exit
 

sonyFOREVER

Reputable
Oct 7, 2014
1
0
4,510
0


I have this same problem, except when I try to release my ip address it tells me that no operation can be performed to wifi while it has it's media disconnected. Help?
 

antholo

Reputable
Nov 25, 2014
1
0
4,510
0
check your wi fi button and router settings firts ,i uninstall the wi fi driver and i did check the settings on my router also however nothing just helped me untill i just got a helpful article and that works for me lenovo helpful solution . i hope same works for you also thank you
 

rahul13579

Reputable
Dec 18, 2014
1
0
4,510
0



Thanks man!..
Really helped!
 

1337LifeH4x0rusR3x

Reputable
Dec 18, 2014
2
0
4,510
0


Well when I did this it says "An error occured while renewing interface WiFi : unable to contact your DHCP server. Request timed out." Any solutions?
 

Rscott6

Reputable
Jan 30, 2015
2
0
4,510
0


Hi Mark, I am getting the same error message as Sonyforever when attempting to renew the IP address, and my wifi switch is definitely on. I am completely stuck, is there anything else I can try?
 

Markkk

Distinguished
Jan 2, 2012
447
0
18,960
74
Restart Device Modem then Laptop

There are a number of reasons these cause connection issues

Modem Settings - Max Number of Connections, Connection Alive time, DHCP server settings, Wifi Settings / Channel / Encryption
Other Enabled DHCP devices on your Wifi giving you ip/gateway settings first (usually Printers)

Your OS will typically resolve this but in some cases it just doesn't and times out Or is holding Old IP settings from connection to other networks, Hence why 'Releasing and Renewing' usually works well in this situation

Sony Also has a Flight Mode on some of its laptops which you will need to turn off
 

Rscott6

Reputable
Jan 30, 2015
2
0
4,510
0


Cheers! Restarting them both did the trick. Thanks for your help
 

Markkk

Distinguished
Jan 2, 2012
447
0
18,960
74
Hi Hairybamboo

It may be best to start a new Topic with your problem

And list the Hardware, o/s and things you have tried and the actual issues with any errors

This way you get fresh eyes and someone may have the same hardware and be able to help quickly
Posting in a Solved Thread although with similar issues wont always get you efficient help
 

Jhenjhen

Reputable
Mar 2, 2015
1
0
4,510
0


ThAnk you marc. Ive tried a lot and this is the only one worked! Ur heaven sent! Mwah
 

stevek66

Reputable
Apr 23, 2015
1
0
4,510
0
I had the same problem - had not had my laptop out in several months and decided to turn it on. It would not connect to my network, but would connect to other networks. After a couple of hours, I almost gave up. But then I thought to check to see if I had allowed my laptop MAC Address through my router's MAC filter - BINGO!
If your router's MAC filter is turned on, check to ensure your laptop is authorized through it. If you do not understand what I am talking about, I doubt your MAC filter is on, so disregard.
 

SMauderer

Reputable
May 18, 2015
2
0
4,510
0
Ctrl+alt+del start task manager. Check for bonjour under processes. If it is running go to control panel under administrator services choose services. Then right click bonjour choose properties set to manual and stop service. Open command prompt type ipconfig /renew If still not working type route service 0.0.0.0&&ipconfig /renew
 

Rej Dimple

Reputable
Jul 26, 2015
2
0
4,510
0


 

Sunny2492

Reputable
Aug 28, 2015
1
0
4,510
0

Well i did a simple thing on my dell, i simply turned on and off my airplane mode 2 or 3 times and than tried to connect to wifi and it worked :)
 

erniyer

Distinguished
Mar 16, 2010
5
0
18,510
0
I just fixed mine. I tried some of the things i found on this site and although it did not fix it, it did led me to the way i got mine fixed. Hope it helps you too.

>Control panel
>network and internet
>network connections- right click to properties, then configure, go to advance then the first one (mine says 802.1 channel width) change it to AUTO.
mine was instantly fixed after. Good luck
 

trisiwi

Reputable
Sep 29, 2015
3
0
4,510
0