Question My LED strip won't turn on when i connect it to PC ?

Sep 26, 2021
4
0
10
0
ok so, i got an ARGB led strip, and a connector for it (to 3pin 5v) i connected it to my CoolerMaster RGB box in the back of the computer, the LED strip won't turn on, and the motherboard doesn't detect it.

The thing is, when i shut down the computer THEN it works for half a second then turns off ?
Motherboard: MSI Z590-A pro
 
This is what it says in the motherboard manual about rgb strips. Does your strip meet these required ratings? ---------> ⚠Important ∙ The JRGB connector supports up to 2 meters continuous 5050 RGB LED strips (12V/G/R/B) with the maximum power rating of 3A (12V). ∙ Always turn off the power supply and unplug the power cord from the power outlet before installing or removing the RGB LED strip. ∙ Please use MSI’s software to control the extended LED strip
 
Sep 26, 2021
4
0
10
0
This is what it says in the motherboard manual about rgb strips. Does your strip meet these required ratings? ---------> ⚠Important ∙ The JRGB connector supports up to 2 meters continuous 5050 RGB LED strips (12V/G/R/B) with the maximum power rating of 3A (12V). ∙ Always turn off the power supply and unplug the power cord from the power outlet before installing or removing the RGB LED strip. ∙ Please use MSI’s software to control the extended LED strip
Well im not using the JRGB because i have 5v LEDs ,i have coolermaster watercooling and thats connected to JRAINBOW, i bought a spliter for the JRAINBOW port maybe that will work
 

ASK THE COMMUNITY