Question My local windows user is unable to run certain apps

dretax

Distinguished
Aug 2, 2015
5
0
18,510
0
I was debugging an application today where randomly my debugger exited with a really long exit code, and I was never able to continue the debug. I went back to gaming a bit, and after finishing up I enabled test signing mode, and rebooted. From there specific applications like visual studio (loads and just crashes without error), snagit (just crashes), Business Skype (crashes), do not start. I'm able to use Rider, Vivaldi, Slack, Discord, FortClient (but cannot connect to VPN), TotalCmd, Putty, WinScp just fine, which indicates that high level / low level apps seem to be running fine, where as some not.

With Rider, I'm getting CL.exe (compile and link) error as well, I'm not entirely sure what black magic is going on. Some installers also produce unexpected error messagebox.

  • I tried sfc and DISM.
  • Reinstalled all VC++ packages / repaired
  • Repaired all my package in Visual Studio
  • Trouble shooted with windows repair
  • Updated to the latest major windows version
  • Tried running these apps via safe mode but failed
  • Ran ESET & MalwareBytes scans
During the repair I once had an error logging into my account from windows, and from that account I could run VS and all the other programs just fine, until i logged back into mine.

I made a new local user and all the apps seem to start without an issue. Looks like something is corrupted in my account?
 

Colif

Win 11 Master
Moderator
Jun 12, 2015
60,531
5,088
166,290
10,419
Could try system restore
on old user
type "restore" then open "create a restore point"
create a new Restore Point now for C-drive
then open the newest restore point that is prior to the problem happening (if you have one)

Otherwise
you could logon to broken account
copy contents of its user folder over top of new user - this gives it same access as before
so go to c:/users
copy contents of old user onto New users folder
if its not admin, make it admin

just use new user. Profiles get broken, sometimes you just have to start a new one.
 

ASK THE COMMUNITY

TRENDING THREADS