Question My M.2 NVMe SSD Boot Drive is no longer detected in BIOS ?

Mar 27, 2023
There was a short power outage while my pc was in sleep mode. Normally, this doesn't really affect anything and it usually just shuts down just like this time. Only now when I turn it back on it displays a message that says " No operating system found -- Try disconnecting any drives that don't contain an operating system ".

I went into BIOS and saw that the system was recognizing my other 2 drives (an SSD and a Hard Drive), but not my M.2 NVMe (which is my boot drive). I tried looking for solutions online to no avail. I tried pulling the CMOS battery out and putting it back in. I tried putting the M.2 drive in the other M.2 slot, which also didn't work. I tried looking for some type of M.2 configuration in the BIOS, but found nothing. I've used this PC in this exact configuration for years now and didn't really have any issues before. Here are my specs:

CPU: AMD Ryzen 5 1600x
GPU: GTX 1050Ti
Motherboard: Gigabyte Aorus X470 Gaming 5 Wifi (rev.1.0)
M.2 NVMe Drive: Aorus RGB M.2 NVMe SSD 512GB
Any help would be greatly appreciated! (Sidenote: The drive itself still lights up and heats up when I'm in the BIOS, though I don't know if that guarantees that it's still alive.)

Update: I have installed a newer BIOS version (F5), it does now feature some sort of M.2 menu and when I check it it does display the drive, however it just gives basic info and says that the drive has 0GB of storage for some reason (corrupted maybe?). Also there is nothing to configure in that menu. After that I tried turning off CSM, nothing. Then I installed a fresh Windows onto my other SSD, and unsurprisingly the problem drive still isn't showing up, neither in the BIOS, nor in Windows Explorer.
Last edited:


Welcome to the forums, newcomer!

says that the drive has 0GB of storage for some reason (corrupted maybe?
That seems to me that the SSD conked out, if you're under warranty, move towards an RMA.

To rule out your motherboard/BIOS being the root cause, perhaps take the M.2 drive over to a known working donor platform/motherboard and see if the culprit SSD is showing up there. Might want to flash the BIOS to the latest version gradually working your way to the latest, please don't skip to the latest version.