My mobo broke (I think) need help please


Aug 17, 2010
Hi everybody,

I'm really in need of some advice.
#1 any tips for my problem – I think it is the mobo?

#2 any advice on whether i should get the same mobo or a new one? (based on my hardware spec listed below)

My issue:
My computer stopped working about 2 months ago. It was working fine for 2years and then one day it crashed with blue screen error. Few weeks later it started doing some beeping every now and then when I turned it on. But if you turn it off and then on again it was fine. Then 2 months ago, it started the beeping again, only now it has never booted properly. Tried few 100 times- and not one boot. Checked all cables and they were connected fine.

I Built it myself with help from a mate.
When i turn it on it does not finish the bios check it just does 2 short beeps, then shuts down. And then repeats the same process over and over. I checked the beep codes (it's award bios) and it suggests maybe a CMOS issue.

So on the weekend I tested:

* Power supply voltage with a multimeter and it was 100% perfect.
* tested all memory sticks and all slots and the beeps still happened, so that is not the issue I guess.
* tested the graphics card by taking it out. the beeps still happened, so that is not the issue I guess.
* so then I tried the CMOS. I did the two methods of clearing it : by a) shorting the CMOS plugs. This made no difference to the problem, so then I b) removed the battery for a few mins. the beeps still happened, so that is not the issue I guess.

So that leaves mobo or CPU then??

My mate suggested that I get a new mobo and try that. As I didn't overclock the CPU and it's only 2yrs old and it's a CPU known to be very overclockable.

The mobo is a gigabyte ga p35-ds3p. The good thing about getting the same mobo is I can just plug and play in a way – i won't need to update drivers etc. So that is a plus for not updating my mobo.

But is this still a good mobo? What are your thoughts? Is it worth me upgrading the mobo or not???

I will now give you my system details so you can use it to help understand my situation.
My system:
CPU: Intel Core 2 Duo E8400 3.00GHz 775-Pin
Motherboard: Gigabyte P35-DS3P
RAM: Corsair QUAD2X4096-8500C5DF 4GB (4x XMS2 1GB) PC-8500 (1066MHz) DDR2 RAM, 4x240-pin DIMMs, Non ECC Unbuffered, 5-5-5-15, Dominator Airflow Fan
HDD: Western Digital 500GB SATAII 16MB Cache
CASE: Thermaltake Armor Silver VA8000SWA
PSU: Corsair hx-520 520W
GPU: Gigabyte 8800GTS 512MB
CPU Cooler & Fan: thermalright ultra 120 extreme with Scythe SFLEC-F (1600rpm)

Thanks in advance for any help you can give me, cheers.
Did you press the power button when you tried the shorting of the CMOS pins and also after removing the battery ?? - this will release any stored power and is what resets the CMOS to default states (If you didn't try it again since it may not have reset !)


Latest posts