My Modern Warfare2 now freezes @ main menu on launch

INeedSomeAdvice

Distinguished
Jun 22, 2010
72
0
18,640
2
I recently crossfired my video cards, and now MW2 freezes at the main menu after launch. Sometimes it will run (after anywhere from 20-100 attempts to launch the game). When running my single GPU xfx HD 5770 I had no problems and settings were max @ 1920x1080 (I crossfired for other games performance benefits). My only other steam game, L4D2 runs perfect, and I mean perfect with max settings, so I dont believe it to be a steam issue. IMO it's driver or software related, but any input from the miracle workers at Tom's would be appreciated.

I've read a few posts from others crossfiring 2x hd 5770's playing mw2 fine. So im confuzzled.........

Side note: I played with catayst A.I settings, Standard, Advanced, and Disabled to no avail. I've been considering a driver rollback to 10.5, and then 10.4, but am not wanting to do so.



AMD 965BE@stock // ASUS M4A78T-E // 2x2 Dominator-GT DDR3 1600 @ stock 1333 mobo // Corsair TX850 psu // 2x HD5770s // CM HAF 932 AMD LE Case/
 

jefe323

Distinguished
Feb 14, 2010
1,471
0
19,460
85
have you tried waiting it out. I know on my system (and i've read a lot of posts by others) that mw2 tends to freeze at the main menu. Try waiting a couple of minutes and see if it starts to respond.

For me, it usually takes between 30-60 sec
 

INeedSomeAdvice

Distinguished
Jun 22, 2010
72
0
18,640
2




Tried a re-installation, made no difference. Re-installing the drivers were first, than the game. =(
 

INeedSomeAdvice

Distinguished
Jun 22, 2010
72
0
18,640
2





I've waited maybe 30 seconds or longer with no results. I could try giving it a little more time. I'm thinking about going back to 10.5, but others are still running their game on CCC 10.6. My frustration levels are growing and so I'm considering a format. It wouldnt hurt but is time consuming.
 

INeedSomeAdvice

Distinguished
Jun 22, 2010
72
0
18,640
2
I rolled back my drivers from 10.6 to 10.4, ran driver sweeper, and ccleaner. So far modern warfare 2 has launched perfectly everytime ive tried. And the driver rollback also took care of some other major problems I was experiencing with BFBC2 and Borderlands.

Thankfully the 10.4 drivers are working great, I was considering a format, but not looking forward to it. =)

Thanks for everyones advice.
 

Similar threads


ASK THE COMMUNITY