Question My monitor constantly goes black and on start up often times the refresh rate goes down to 24 hertz

Gracodana

Distinguished
Jul 4, 2013
1,833
0
20,160
173
So there are a couple layers to this. On startup what quite commonly happens is my main monitor(I have two) goes black because it has a loose display port cable. This isn't such a huge issue but with the other issues it's a nightmare. While I'm jiggling around with the cable to get it in the right way the graphics card sometimes refuses to post. I get a black screen on both monitors and the machine doesn't respond to any commands(I've tried using the sleep function or ctrl alt delete to no avail). Once this happens I usually just have to restart the computer and try again. Usually it's not a huge bother and I am ready to go in about 30 seconds of fiddling but sometimes it can be 10+ minutes of fiddling and restarting.

To make matters worse, when I start up the monitor(my main monitor) will go to 24 hertz. Occasionally I can just change it in the Nvidia settings but usually I have to unplug and replug the monitor until it goes back to normal. At which point, you guessed it, the screens can go black and I have to restart.

One thing to note is that my gpu is fairly heavy(1070 ti) and has a bit of sag in the pci slot. I've had a bit of a look round and it seems that that's okay(within reason). I've rechecked all the connections into the gpu and there aren't any loose cables. What is weird is sometimes the fan will stop spinning but I seem to have fixed that by msi afterburner opening on startup. Worth noting, once all the faffing is done the PC has no performance issues, games run smoothly and there's no stuttering.

Many thanks for any help, it's been driving me nuts.
 

Gracodana

Distinguished
Jul 4, 2013
1,833
0
20,160
173
full system spec? include make and model of the psu
monitor is Asus predator 1440p gsync 165hertz.

Geforce gtx 1070 ti Palit
i5 8600k
Noctua NH D14 air cooler
Asrock Z370 Extreme4 motherboard
I can't remember the exact modal of the psu but it's a Corsair 860w 80+Gold(might have been platinum) It was definitely a tier 1 or 2 on the Toms Hardware psu's but that was a few years ago.
Corsair vengeance ddr4 16gb RAM

I think that's all the necessary hardware. There's a wifi card in there. I don't think the hdd would possibly be an issue.
 

ASK THE COMMUNITY

TRENDING THREADS