Question My Network Card always gives error on cold/hard boot ?

NeonStrnz0

Distinguished
BANNED
Sep 26, 2010
31
1
18,530
0
Hello,
I am using GA-Z77X-UP5-TH motherboard.
Everytime I cold/hard boot my computer (turn on electric power buttons then turn on PC)
My Network card gives error (yellow asterisk appears besides card).
I have to uninstall network card, then scan for hardware changes and the same appears properly..


Please help fix this issue.

Thanks.
 

Lutfij

Titan
Moderator
Which BIOS version are you currently on for your motherboard? As for your OS, since you posted in the Windows 10 section, what version(not edition) of the OS are you working with? You might want to try manually reinstalling your driver for the networking adapter in an elevated command(after sourcing the latest driver from Gigabyte's support site or from Intel's support site, if they have it) i.e, Right click installer>Run as Administrator, when you uninstall it, without rediscovering the device using Device Manager.
 
Reactions: NeonStrnz0

NeonStrnz0

Distinguished
BANNED
Sep 26, 2010
31
1
18,530
0
Which BIOS version are you currently on for your motherboard? As for your OS, since you posted in the Windows 10 section, what version(not edition) of the OS are you working with? You might want to try manually reinstalling your driver for the networking adapter in an elevated command(after sourcing the latest driver from Gigabyte's support site or from Intel's support site, if they have it) i.e, Right click installer>Run as Administrator, when you uninstall it, without rediscovering the device using Device Manager.
Hello,
Windows 10 Pro, Version - 21H2
OS Build - 19044.1806
Experience - Windows Feature Experience Pack 120.2212.4180.0

Bios Details:
 

NeonStrnz0

Distinguished
BANNED
Sep 26, 2010
31
1
18,530
0
Uninstalled previous drivers as instructed.
I found Windows 10 drivers on official Gigabyte site.
Installed same.

Hard/Cold Boot now.
 

NeonStrnz0

Distinguished
BANNED
Sep 26, 2010
31
1
18,530
0
This did not worked :(
Network Card again appears with problems as in first post.
Cannot find 82579LM Network drivers on intel website for Windows 10 PRO
 

Ralston18

Titan
Moderator
Look in Reliability History and Event Viewer. Either one or both may be capturing some other related error codes, warnings, or even an informational event that you can match to the adapter failures.

As I understand your post you are able to recover by uninstalling the network card, etc.... Correct?

Compare the event entries from when the failure occurs to event entries that appear after the uninstall and successful start of the network adapter.

Reliability History presents a time line format that may highlight some pattern of events.

You can also run the built in Windows troubleshooters. The trouble shooters may find and fix something.

Posssibly corrupt or buggy Windows files.

Try "sfc /scannow" and "dism".

References:

https://www.lifewire.com/how-to-use-sfc-scannow-to-repair-windows-system-files-2626161

https://www.windowscentral.com/how-use-dism-command-line-utility-repair-windows-10-image
 
Reactions: NeonStrnz0

NeonStrnz0

Distinguished
BANNED
Sep 26, 2010
31
1
18,530
0
Look in Reliability History and Event Viewer. Either one or both may be capturing some other related error codes, warnings, or even an informational event that you can match to the adapter failures.

As I understand your post you are able to recover by uninstalling the network card, etc.... Correct?

Compare the event entries from when the failure occurs to event entries that appear after the uninstall and successful start of the network adapter.

Reliability History presents a time line format that may highlight some pattern of events.

You can also run the built in Windows troubleshooters. The trouble shooters may find and fix something.

Posssibly corrupt or buggy Windows files.

Try "sfc /scannow" and "dism".

References:

https://www.lifewire.com/how-to-use-sfc-scannow-to-repair-windows-system-files-2626161

https://www.windowscentral.com/how-use-dism-command-line-utility-repair-windows-10-image
Thank You for your reply, Reliability History is not showing anything except for 3 days ago, when had few system errors, fixed those using sfc /scannow and DSIM

Cleared all Even Viewer logs and shut down PC.
Logs from Application and Security are Information and Success (i assume no errors there)
Here are logs From Windows Event Viewer - System


This is the complete log file for Ethernet Card Warning:
Code:
Log Name:      System
Source:        e1i65x64
Date:          08-07-2022 1.19.10 AM
Event ID:      27
Task Category: None
Level:         Warning
Keywords:      Classic
User:          N/A
Computer:      MyRoom
Description:
Intel(R) 82579V Gigabit Network Connection
 Network link is disconnected.

Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="e1i65x64" />
    <EventID Qualifiers="40964">27</EventID>
    <Version>0</Version>
    <Level>3</Level>
    <Task>0</Task>
    <Opcode>0</Opcode>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2022-07-07T19:49:10.0063839Z" />
    <EventRecordID>3229</EventRecordID>
    <Correlation />
    <Execution ProcessID="4" ThreadID="10932" />
    <Channel>System</Channel>
    <Computer>MyRoom</Computer>
    <Security />
  </System>
  <EventData>
    <Data>
    </Data>
    <Data>Intel(R) 82579V Gigabit Network Connection</Data>
    <Binary>0000040002003000000000001B0004A00000000000000000000000000000000000000000000000001B0004A0</Binary>
  </EventData>
</Event>
Event Log Online Help link:
https://go.microsoft.com/fwlink/events.asp?ProdName=Microsoft®+Windows®+Operating+System&ProdVer=10.0.19041.1&EvtID=27&EvtSrc=e1i65x64&LCID=16393

Also noted that many times while viewing Windows Logs the Microsoft Management console gets stuck and I have terminate the same from Task Manager, this is the event log and image for same:

Code:
Log Name:      Application
Source:        Application Hang
Date:          08-07-2022 1.38.35 AM
Event ID:      1002
Task Category: (101)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      MyRoom
Description:
The program mmc.exe version 10.0.19041.1806 stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Security and Maintenance control panel.
 Process ID: 4bc
 Start Time: 01d8923d34d04cd8
 Termination Time: 4294967295
 Application Path: C:\Windows\System32\mmc.exe
 Report Id: 9066560f-167f-445b-8506-7e13fea6e0fd
 Faulting package full name:
 Faulting package-relative application ID:
 Hang type: Cross-thread

Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Application Hang" />
    <EventID Qualifiers="0">1002</EventID>
    <Version>0</Version>
    <Level>2</Level>
    <Task>101</Task>
    <Opcode>0</Opcode>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2022-07-07T20:08:35.0393147Z" />
    <EventRecordID>2884</EventRecordID>
    <Correlation />
    <Execution ProcessID="0" ThreadID="0" />
    <Channel>Application</Channel>
    <Computer>MyRoom</Computer>
    <Security />
  </System>
  <EventData>
    <Data>mmc.exe</Data>
    <Data>10.0.19041.1806</Data>
    <Data>4bc</Data>
    <Data>01d8923d34d04cd8</Data>
    <Data>4294967295</Data>
    <Data>C:\Windows\System32\mmc.exe</Data>
    <Data>9066560f-167f-445b-8506-7e13fea6e0fd</Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>Cross-thread</Data>
    <Binary>430072006F00730073002D00740068007200650061006400000044006500610064006C006F0063006B00000054006F00700020006C006500760065006C002000770069006E0064006F0077002000690073002000690064006C00650000000000</Binary>
  </EventData>
</Event>
 

Ralston18

Titan
Moderator
Ensure that only one network adapter either wired or wireless is enabled. Not two adapters of any sort enabled at the same time.

If wired, have you tried swapping in a known working Ethernet cable?

Run "ipconfig/all" without quotes via the Command Prompt and post the results.

PSU: make, model, wattage, age, condition (original to build, new, refurbished, used)?
 
Reactions: NeonStrnz0

NeonStrnz0

Distinguished
BANNED
Sep 26, 2010
31
1
18,530
0
Ensure that only one network adapter either wired or wireless is enabled. Not two adapters of any sort enabled at the same time.

If wired, have you tried swapping in a known working Ethernet cable?

Run "ipconfig/all" without quotes via the Command Prompt and post the results.

PSU: make, model, wattage, age, condition (original to build, new, refurbished, used)?
Thanks again for quick reply, I only have 1 ethernet port and card on my PC
Other is Virtual/Wifi Network card which is run as a hotspot to provide internet connectivity to my mobile. Using Connectify software for same.

Ipconfig /all results:
Code:
C:\Users\Panav>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : MyRoom
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : lan

Wireless LAN adapter Wi-Fi:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Qualcomm Atheros AR5BWB222 Wireless Network Adapter
   Physical Address. . . . . . . . . : 74-E5-43-D3-58-6E
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Local Area Connection* 1:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft Wi-Fi Direct Virtual Adapter
   Physical Address. . . . . . . . . : 16-E5-43-D3-58-6E
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Local Area Connection* 10:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft Wi-Fi Direct Virtual Adapter #2
   Physical Address. . . . . . . . . : 26-E5-43-D3-58-6E
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Ethernet adapter Ethernet:

   Connection-specific DNS Suffix  . : lan
   Description . . . . . . . . . . . : Intel(R) 82579V Gigabit Network Connection
   Physical Address. . . . . . . . . : 90-2B-34-57-76-E9
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   IPv6 Address. . . . . . . . . . . : fdcb:1139:1f33::e38(Preferred)
   Lease Obtained. . . . . . . . . . : 08 July 2022 1.32.48 AM
   Lease Expires . . . . . . . . . . : 14 August 2158 8.31.14 AM
   IPv6 Address. . . . . . . . . . . : fdcb:1139:1f33:0:e089:acdd:b9b5:f7cd(Preferred)
   Temporary IPv6 Address. . . . . . : fdcb:1139:1f33:0:94fe:d481:2f15:d911(Preferred)
   Link-local IPv6 Address . . . . . : fe80::e089:acdd:b9b5:f7cd%19(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.1.121(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : 08 July 2022 1.32.48 AM
   Lease Expires . . . . . . . . . . : 08 July 2022 1.32.48 PM
   Default Gateway . . . . . . . . . : 192.168.1.1
   DHCP Server . . . . . . . . . . . : 192.168.1.1
   DHCPv6 IAID . . . . . . . . . . . : 143665972
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-2A-51-FC-FA-90-2B-34-57-76-E9
   DNS Servers . . . . . . . . . . . : fdcb:1139:1f33::1
                                       192.168.1.1
                                       fdcb:1139:1f33::1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Wireless LAN adapter Local Area Connection* 11:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft Hosted Network Virtual Adapter
   Physical Address. . . . . . . . . : 56-E5-43-D3-58-6E
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::a93c:3cf2:bcf8:acf5%15(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.89.1(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . :
   DHCPv6 IAID . . . . . . . . . . . : 811001155
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-2A-51-FC-FA-90-2B-34-57-76-E9
   DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                       fec0:0:0:ffff::2%1
                                       fec0:0:0:ffff::3%1
   NetBIOS over Tcpip. . . . . . . . : Enabled
 

Ralston18

Titan
Moderator
First - Disable IPv6. Determine if the error ends.

Second - Temporarily disable that" Virtual/Wifi Network card which is run as a hotspot "

The immediate objective being to restore/recover a wired and stable Ethernet network connection.
 
Reactions: NeonStrnz0

NeonStrnz0

Distinguished
BANNED
Sep 26, 2010
31
1
18,530
0
First - Disable IPv6. Determine if the error ends.

Second - Temporarily disable that" Virtual/Wifi Network card which is run as a hotspot "

The immediate objective being to restore/recover a wired and stable Ethernet network connection.
Truly appreciate your quick responses. Thanks will do same.

Results of:
C:\Windows\system32>sfc /scannow

Beginning system scan. This process will take some time.

Beginning verification phase of system scan.
Verification 100% complete.

Windows Resource Protection found corrupt files but was unable to fix some of them.
For online repairs, details are included in the CBS log file located at
windir\Logs\CBS\CBS.log. For example C:\Windows\Logs\CBS\CBS.log. For offline
repairs, details are included in the log file provided by the /OFFLOGFILE flag.


Link to CBS.LOG file in .zip format uploaded on google drive:
https://drive.google.com/file/d/11r4UwEmqZ0mfJzNO_Fraugg90rgP5J1q/view?usp=sharing
 

NeonStrnz0

Distinguished
BANNED
Sep 26, 2010
31
1
18,530
0
This are results from DISM tool:
Code:
C:\Windows\system32>DISM /Online /Cleanup-Image /CheckHealth

Deployment Image Servicing and Management tool
Version: 10.0.19041.844

Image Version: 10.0.19044.1806

The component store is repairable.
The operation completed successfully.

C:\Windows\system32>DISM /Online /Cleanup-Image /ScanHealth

Deployment Image Servicing and Management tool
Version: 10.0.19041.844

Image Version: 10.0.19044.1806

[==========================100.0%==========================] The component store is repairable.
The operation completed successfully.

C:\Windows\system32>
 

NeonStrnz0

Distinguished
BANNED
Sep 26, 2010
31
1
18,530
0
I just noted following information too:
The Windows 10 release I have installed is:
Version: 21H2
OS Build: 19044.1806
Experience: Windows Feature Experience Pack 120.2212.4180.0

I just download latest Windows 10 Pro ISO from Microsoft using MediaCreationTool21H2.exe
Here are details for same:
C:
PS C:\Windows\system32> dism /get-wiminfo /wimfile:F:\sources\boot.wim /index:1

Deployment Image Servicing and Management tool
Version: 10.0.19041.844

Details for image : F:\sources\boot.wim

Index : 1
Name : Microsoft Windows PE (x64)
Description : Microsoft Windows PE (x64)
Size : 1,735,189,011 bytes
WIM Bootable : No
Architecture : x64
Hal : <undefined>
Version : 10.0.19041
ServicePack Build : 1288
ServicePack Level : 0
Edition : WindowsPE
Installation : WindowsPE
ProductType : WinNT
ProductSuite :
System Root : WINDOWS
Directories : 4808
Files : 17165
Created : 07-12-2019 - 12.39.54 PM
Modified : 08-07-2022 - 2.10.48 AM
Languages :
        en-US (Default)

The operation completed successfully.
PS C:\Windows\system32>
Wonder if I am using latest copy of Windows 10 PRO ?
 

NeonStrnz0

Distinguished
BANNED
Sep 26, 2010
31
1
18,530
0
Hello Members, @Ralston18 @Lutfij
Thank You very much for your help and contribution, just an update.
My Network Card issue resolved automatically without any further debugging, its properly enabled on every booth since last 2 weeks now, on both cold/hot boot.
 
Reactions: Lutfij

ASK THE COMMUNITY

TRENDING THREADS