Question My new build won't post

Jan 17, 2020
3
0
10
0
Hi all... So I have a new build. The motherboard will not post and no boot. I tried every troubleshooting step in the book.

all parts are brand new. Here is a list of the parts.

  • GIGABYTE X470 AORUS Gaming 7 WIFI-50
  • AMD Ryzen 7 2700X 8-Core 20 MB Cache 105 W CPU
  • MSI GeForce RTX 2060 DirectX 12 RTX 2060 VENTUS XS 6G OC 6GB 192-Bit GDDR6
  • 2x Corsair Vengeance LPX 16GB (2x8GB)
  • Crucial P1 500GB 3D NAND NVMe PCIe M.2 SSD
  • EVGA SuperNOVA 750 G3, 80 Plus Gold 750W Power Supply
  • NZXT H500 ATX Mid Tower
I tried with one ram, two rams, and in different slots. I also tried different types of ram. I tried without graphics card, and without ram and without both. Then tried without ssd... I tried all the combinations. Triple checked the wires and changed them twice just in case. I reset the mb battery, tried all bios boot options (primary and secondary that comes as option, two switches on the physical mb).

Running out of options at this point... Not sure what's wrong. Anyone know what could cause this?
 

TLGalenson

Reputable
Nov 19, 2016
17
1
4,510
0
Trade out your PSU if possible. Is the board designed to light up? Does it light up? Do you have another AM4 socket motherboard?

Have you tried to boot the motherboard out of the case (could be a short back there)?

If the MB lights up but won't boot and it is under warranty you may need to RMA# back to where you bought it.

Tom (no relation)
 
Reactions: Drog
Jan 17, 2020
3
0
10
0
What's wrong with the PSU? what do I trade it with?

The board lights up and everything works but it doesn't boot. I tried the cpu on another msi b450 board and it worked. I tried the same part I have on a x570 mobo I get the same problem. both mobo aorus x470 and x570 are not booting.

No idea what to do now...
 
Jan 17, 2020
3
0
10
0
Update...

I am returning the x470 since it didn't boot at all no matter what I tried I even swapped the cpu to the 3700x and still didn't work. I tried the 2700x on x470 and the x570 and it didn't work on either although it is supported and I know for a fact that it works with these boards.. But it didn't work so I am returning that as well and upgrading it to the 3700x which I tested and works well with the x570...

I am really confused cause I tried that 2700x cpu on an msi x470 board and it worked. I am a bit worried they would not return it. I am also confused af with these aorus boards.
 

ASK THE COMMUNITY

TRENDING THREADS

Latest posts