My New Computer Build Not Booting In Bios Or Nothing Happens When I Press Power Button

aniketj367

Prominent
Sep 10, 2017
2
0
510
0
SPECS :-
Motherboard=ASUS H61M-K Socket LGA 1155
Processor=Core I5 3570
Ram=8+2 GB DDR3 1333 MHZ
Hard Disk=Western Digital Blue 1 TB
Grafics card=Nvdia GTX 710 2 GB
Cooling System=1 Cpu Fan+2 Normal Fans

This Is My New Pc Build
I Assembled all Parts And After That I Plugged in and Power it on The SMPS Doesn't Started Or Responded But There is A Small Led on Motherboard That Lights Up Please Help Me
Thanks In Advanced
 
1. Double check all the cables from your power supply are plugged in properly.
2. Make sure the wire from the power button is plugged correctly into the motherboard header.
3. Clear the CMOS.
4. Try booting with just 1 stick of RAM, then try the other stick.
 

Coolness94

Commendable
Dec 28, 2016
63
0
1,660
5
1. Try recycling the power.
Turn it completely off and on again a few times. My first build worked after I tried booting it 5 or so times.

2. If not then slowly remove parts and try booting to see if there is a faulty part.

3. Don't try your first boot up on a GPU, use the motherboard then switch over to your GPU after you install your OS

4. Try removing the GPU and connect your monitor to your motherboard, sometimes the GPU shorts power from the CPU; even if you have a nice PSU (This method surprisingly worked on my third build for me.)

Question, does the build even post? If it doesn't even post then my 4 suggestions should help you.