[SOLVED] my new GPU suddenly stopped working

Status
Not open for further replies.
Dec 6, 2022
5
0
20
0
This is in a brand-new build I just got up and running late last night and was all working perfectly except for the headphone jack.

Today all I did was plug that loose audio cable back in correctly, and now my new GPU(XFX Speedster SWFT 319 Radeon RX 6800 16 GB) absolutely will not turn on no matter what I do. I've already tried:
-resettling it
-rewiring it
-plugging it into a different slot
-toggling the switch that's on it
-unplugging the audio cable just in case
-and resetting BIOS

Everything else appears to be running fine, but this PC doesn't have integrated graphics nor do I have any other graphics cards lying around so until I can fix this GPU the whole thing's a brick. Please help!!
 

Darkbreeze

Retired Mod
So, when you turn the power on, what happens? Is the board powering up, fans running, lights on, etc?

Are you getting any debug lights or beep codes? Do you even have a system speaker connected to the motherboard, like this:





Does the graphics card light up at all? Graphics card fans come on? Or is the whole system just "dead"?
 
Dec 6, 2022
5
0
20
0
So, when you turn the power on, what happens? Is the board powering up, fans running, lights on, etc?

Are you getting any debug lights or beep codes? Do you even have a system speaker connected to the motherboard, like this:





Does the graphics card light up at all? Graphics card fans come on? Or is the whole system just "dead"?
motherboard, processor, fans, lights, everything's working except for the GPU.

At least as far as i can tell. i don't have a system speaker(that i know of, this is all new so maybe one of the components came with one) and don't know how to decipher lights, but i haven't heard any beeping at least.

Also the GPU's connector lights do come on sometimes when i jostle its power cable or shut the PC down, so maybe it's receiving power at least?
 

Darkbreeze

Retired Mod
Are the fans coming on on the graphics card? Are you SURE you are fully seating the power cables to the graphics card and that you have the display cables connected to the graphics card and not the motherboard outputs?
 
Dec 6, 2022
5
0
20
0
Are the fans coming on on the graphics card? Are you SURE you are fully seating the power cables to the graphics card and that you have the display cables connected to the graphics card and not the motherboard outputs?
the fans on the GPU are the only ones that are not turning on. I hope it's just seated or wired incorrectly, but i've spent 3 hours today alone situating and re-situating it every which way i can think of to no avail.
 

Darkbreeze

Retired Mod
If the card is fully seated so that the PCIe lock at the end of the slot is engaged with the cutout on the bottom of the graphics card, and the graphics card's PCIe bracket is attached to the I/O slot at the back of the case, and the auxiliary power cables are fully plugged into the graphics card, and the fans are not turning, then you either have a faulty card or a problem with the CPU like a bent pin or pins.

I'd probably pull the CPU first to make sure there are no bent pins and if there are not then I'd RMA the graphics card. Assuming of course that your XPG core reactor is also new and doesn't have a bunch of miles on it.
 
Status
Not open for further replies.

ASK THE COMMUNITY