My new pc sucks

May 14, 2018
5
0
10
0
So i just i recently built my pc i have a amd ryzen 3 2200g with radeon vega graphics and 16 g ram with no graphics card a corsair 650 piwer supply and a 2T hard drive. I mainly got this pc to play fortnite and then it wont play it saying dx11 version 10.00 and then a few weeks later i than tried to play world of warships and ir ran 2 fps and was on low graphics, something cant be right hardeware wise on my pc correct?
 

justin.m.beauvais

Respectable
Dec 15, 2017
1,124
43
2,290
240
Sounds to me like you've got a software configuration issue somewhere. Have you downloaded the latest system and driver updates? If you are getting video then everything seems to be working hardware wise.

What version of Windows are you running? Did you download AMD's drivers or are you using Windows drivers? Does all your hardware show up properly in Device Manager?
 
May 14, 2018
5
0
10
0


 
May 14, 2018
5
0
10
0
Im running on windows 10 and everything says on device manager is running fine except when i got to windows trouble shoot hardware and driver there is a problem but it cant figure whats wrong and i dont know much about the amd drivers and it says im using windows drivers i THINK
 

justin.m.beauvais

Respectable
Dec 15, 2017
1,124
43
2,290
240
Well, I'd head on over to AMD's website and download the latest drivers for your GPU and see if that helps. There should be a link on the main page for drivers, then either use the auto detect software or select your 2200G's drivers from the drop down menus. Download and install the drivers and see if that helps.

If it doesn't then we can go from there. I think it is just a driver issue at this point so this should fix it.
 
May 14, 2018
5
0
10
0


 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS