Question My newly built PC won't turn on?

Aug 30, 2020
2
0
10
0
I built my first PC and I'm having trouble booting it up. I've checked countless times and it looks like everything is plugged in correctly and the SSD and CPU/CPU Cooler are in correctly. I tested my PSU independently doing the paper clip test and the fan started, but when I try it with everything plugged in it won't start. I looked through the troubleshooting checklist on Tom's and checked every step to see what could be wrong. I can't figure out if this is a motherboard problem, a PSU problem (maybe it isn't powerful enough?) or something else. I've taken it all apart and put it all back together a couple times but nothing changed, and I tried booting it up with the graphics card disconnected and still no power. Any help you guys can give would be amazing. If you need any pictures I can post them. Thank you!

Parts: (all are brand new)

PSU: EVGA 650 GQ 80+ Gold

Motherboard: ROG STRIX B450-F Gaming

Case: NZXT H510i

Graphics Card: ASUS Geforce GTX 1660 Super

CPU: AMD Ryzen 5 2600

SSD: Samsung 970 evo

Memory: Corsaire Vengeance pro 16gb
 

RealBeast

Titan
Moderator
Check your memory model and see if it is on the motherboard QVL for use with a Ryzen 2XXX CPU. Vengeance has some models that are not, and you will need to boost the voltage and slow the speed (like 2133MHz) in many cases.

For example, this model is not on the QVL: CMW16GX4M2C3200C16
 
Aug 30, 2020
2
0
10
0
Is there a way to boost the voltage while the computer is not on? Or do you recommend that I get new memory that is on the QVL for my motherboard? My PSU doesn't have a switch to adjust the voltage. Thanks i'm pretty new to all of this
 

ASK THE COMMUNITY

TRENDING THREADS