[SOLVED] My old PC would disconnect my monitor so i got a new PC, long and behold my PC is doing the same and is sluggish

Aug 15, 2021
2
0
10
0
Acer Predator XB272- Monitor
Gigabyte Z590 UD AC- Motherboard
Nvidia GeForce RTX 3080 Graphics Card EVGA - Graphics Card
Inter core i9-10850k processor
16 gb of ram
_
I tried to scan all of my drivers and update, ive tried to use a completely different PC, i have tried a new display port cable.
this PC is a BRAND NEW BUILD. why does it feel like a PC from 1995
 

hang-the-9

Titan
Moderator
Mar 25, 2010
60,352
1,070
152,940
16,851
Could it be possible that the power coming out of my outlet in my wall is not putting out enough power to run my PC to the best of its ability. Or is that not possible.
No that is not possible. However you did not list the power supply in the computer, which is pretty important.

You said it was a new build, it this something you built or did you buy it pre-built? If it was prebuilt did you contact the place you bought it from? What exactly is happening with the system, the monitor blanks out in middle of it running? If it's slow, is it slow in everything, slow startup, slow opening programs? Has it been doing this since you got it or after you used it and maybe copied some files you had to it? Did you do a virus scan?
 
Aug 15, 2021
2
0
10
0
Could it be possible that the power coming out of my outlet in my wall is not putting out enough power to run my PC to the best of its ability. Or is that not possible.
 

hang-the-9

Titan
Moderator
Mar 25, 2010
60,352
1,070
152,940
16,851
Could it be possible that the power coming out of my outlet in my wall is not putting out enough power to run my PC to the best of its ability. Or is that not possible.
No that is not possible. However you did not list the power supply in the computer, which is pretty important.

You said it was a new build, it this something you built or did you buy it pre-built? If it was prebuilt did you contact the place you bought it from? What exactly is happening with the system, the monitor blanks out in middle of it running? If it's slow, is it slow in everything, slow startup, slow opening programs? Has it been doing this since you got it or after you used it and maybe copied some files you had to it? Did you do a virus scan?
 

ASK THE COMMUNITY