Question My PC can't run games like Overwatch and Apex Legends

Oct 5, 2022
4
0
10
0
I don't exactly know when this all started to happen but in the past, I was able to run Apex Legends and Overwatch 1 on my computer just fine. However, after trying to get back to Apex, and Overwatch after Overwatch 2 just dropped, I noticed that they kept crashing on startup. On Apex it would start the respawn entertainment loading cinematic and would instantly close afterwards. On Overwatch 2 it would simply go black on startup then crash. I've tried to reinstall both games, verify/repair game files, delete certain files like remaining .dll files from razer synapes, update both windows and graphics drivers, but to no avail. I'm aware that this maybe caused by my outdated components, but as of now I don't have the funds to build a new one.

For reference, here is my specifications:

CPU: Intel(R) Core(TM) i5-6400 CPU @ 2.70GHz
GPU: AMD RX 570
RAM: 6GB
OS: Windows 10

I'm hoping that I may be able to get the answer from this forum. Thank you in advance to whoever helps!
 

Lutfij

Titan
Moderator
Welcome to the forums newcomer!

Please list your specs like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
PSU:
Chassis:
OS:
Monitor:
include the age of the PSU, apart from it's make and model.
 
Oct 5, 2022
4
0
10
0
Welcome to the forums newcomer!

Please list your specs like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
PSU:
Chassis:
OS:
Monitor:
include the age of the PSU, apart from it's make and model.
CPU: Intel(R) Core(TM) i5-6400 CPU @ 2.70GHz
Motherboard: ECS H110M4-C3D/C3V
Ram: Kingston 2x4 GB 2133 mhz DDR4
SSD/HDD: Kingston A400 240GB SSD
GPU: AMD Radeon RX 570
PSU: Thermaltake Smart SE 530W (6 years)
Chassis: (Can't remember)
OS: Windows 10 Pro
Monitor: AOC 24G2SE
 

Lutfij

Titan
Moderator
PSU: Thermaltake Smart SE 530W (6 years)
That might very well be your problem, borrow a reliably built 650W PSU from a friend or neighbor and use that to power your build, then see if the issue is alleviated.
 
Oct 5, 2022
4
0
10
0
PSU: Thermaltake Smart SE 530W (6 years)
That might very well be your problem, borrow a reliably built 650W PSU from a friend or neighbor and use that to power your build, then see if the issue is alleviated.
Will do this as soon as possible and I'll come back to this thread after doing so. Thank you so much!
 
Oct 5, 2022
4
0
10
0
Found the fix and it was really simple. I just had to completely delete Razer Synapse files. The chroma .dll files were the ones that caused issues on both Apex and Overwatch. After deleting said files they're now both working!
 

ASK THE COMMUNITY

TRENDING THREADS