Question My PC disconnects from games.

Oct 18, 2020
4
0
10
0
My PC has been disconnecting from every video game I play. My connection in discord also drops and I get a ping spike in discord. This seems to happen every 5- 15 minutes. I have overkill internet with a stable wired connection and have tried hot spotting from my phone. I have turned off power settings in network adapters, but I think this is something else as it still happens when connected to a hot spot.
Things I have tried are
-Flushing DNS
-Not allowing the network to turn off to save power
-restarting PC
-Checked for driver/pc updates
-uninstalling and reinstalling network drivers
-uninstalling and reinstalling audio drivers
- uninstalling and reinstalling graphics and display drivers
(I have tried many more things but these are what I can remember). Could this be a power supply issue? This has been incredibly frustrating for me and I hope someone can help.
 
Oct 18, 2020
4
0
10
0
My PC has been disconnecting from every video game I play. My connection in discord also drops and I get a ping spike in discord. This seems to happen every 5- 15 minutes. I have overkill internet with a stable wired connection and have tried hot spotting from my phone. I have turned off power settings in network adapters, but I think this is something else as it still happens when connected to a hot spot.

Things I have tried are

-Flushing DNS

-Not allowing the network to turn off to save power

-restarting PC

-Checked for driver/pc updates

-uninstalling and reinstalling network drivers

-uninstalling and reinstalling audio drivers

- uninstalling and reinstalling graphics and display drivers

(I have tried many more things but these are what I can remember). Could this be a power supply issue? This has been incredibly frustrating for me and I hope someone can help.
 

InvalidError

Titan
Moderator
A few years ago, I had frequent disconnect issues that I mostly noticed while playing WoW which ultimately turned out to be a combination of both flaky modem occasionally losing sync and flaky router (Asus N66U) randomly rebooting due to what appeared to be anomalous packets from the WAN side based on syslog output which I initially thought were coming from the dying modem but persisted with the new modem. Since changing the router, my networked stuff can stay connected to each other for weeks at a time.
 
Oct 18, 2020
4
0
10
0
I have tried switching between the LAN ports and it has seemed to help. I still get disconnected but less often. I'll see if it gets better as I have only tried the second lan port for a day or so. Thanks so much for the help!
 

ASK THE COMMUNITY

TRENDING THREADS