Question My PC is dying... Bluescreens and hanging

kodydoty

Reputable
Jun 19, 2015
38
0
4,530
0
Hello, i was wondering if anyone could recommend a good diagnostic tool. For the past week my system has been having hang ups and blue screens. Every time my computer blue screens it is a different error. I have had to reinstall windows 3 times now, and every time the system gets corrupted. The most frequent error I get is a driver error, I have updated all the drivers i can at this point. I have been running this system for a little under 6 months and now its failing. I think it could be the GFX card or possibly the power supply. I will link photos of some idle information on the system. I have ran check disk and it comes up with no errors....

i9-9900k
RTX 2080
16 GB 3000mhz
1000W Rosewill Power Supply
MSI Mobo
OS drive is a 500 GB M.2
View: https://imgur.com/a/sWLgBdX

 

R_1

Judicious
Herald
strange bluescreens that are not the same and corrupted files usually lend towards the ram or storage. data gets shuffled into anf f4rom those locations constantly and if there is damage the data stored there gets corrupted.

the M.2 drive maker should have a diagnostic available on the website. download and run the drive through its paces, see what's what.

memtest86 run the RAM through memtest86 for 5 passes. if you get no errors or reboots the RAM is good
 

kodydoty

Reputable
Jun 19, 2015
38
0
4,530
0
strange bluescreens that are not the same and corrupted files usually lend towards the ram or storage. data gets shuffled into anf f4rom those locations constantly and if there is damage the data stored there gets corrupted.

the M.2 drive maker should have a diagnostic available on the website. download and run the drive through its paces, see what's what.

memtest86 run the RAM through memtest86 for 5 passes. if you get no errors or reboots the RAM is good
Okay i will try the memtest and reply with the outcome. I will also search for the SSD diagnostic tool.
 

kodydoty

Reputable
Jun 19, 2015
38
0
4,530
0
Okay so i ran the memtest and there were no errors, i ran tests on all SSDs in my system and they all passed. Maybe my motherboard is messed up?
 

ASK THE COMMUNITY

TRENDING THREADS