Question my pc is underperforming

Apr 17, 2019
10
0
10
0
hello,
here's my situation, i changed my setup in january of this year. I went from a gtx 960 to a gtx 1080 but when i watch reviews on youtube of just talk to my friends i notice that my hole setup is underperforming in games. For example, in overwatch i've got around 140fps but i should have more like 240 and my game is not even on ultra, on rainbow6 i also have between 140 and 150fps even dropping to 120fps and my game is on high preset. League of legends well 175 fps on average... and i game only in 1080p!
Here is my hardware :
  • gigabyte gtx 1080 turbo oc 8g
  • ryzen 5 2600x (3.6 Ghz)
  • corsair vengence ddr4 3000Mhz 8go (got 2 sticks so 16go)
-gigabyte b450M as motherboard.
Nothing is overclocked, i have the latest drivers for everything, I plugged the HDMI cable on my graphics card, my graphics card is on the fastest pcie port.
if you could tell me where's the problem that would be great
thanks in advance ;)
 

Fix_that_Glitch

Upstanding
Mar 31, 2019
308
28
240
6
I would try uninstalling the nvidia drivers with a clean install. When the box opens and ask if you want to do a clean install check it off. After they are installed,then go into Nvidia control panel and reset the settings to your liking. See if this helps your fps.
 
Apr 17, 2019
10
0
10
0
I would try uninstalling the nvidia drivers with a clean install. When the box opens and ask if you want to do a clean install check it off. After they are installed,then go into Nvidia control panel and reset the settings to your liking. See if this helps your fps.
i've already done this several times unfortunatly it doesn't work :(
 
Apr 17, 2019
10
0
10
0
so i just openned msi afterburner to check the tem and the first think i noticed without even running a game with is it that my memory clock speed is 50% less than what is advertised on the manufacturer box and software
http://fr.tinypic.com/r/2aane4h/9
edit : msi afterburner says 5000 mem clocks while my aorus engine says 10 000
 

drivinfast247

Notable
May 29, 2018
1,466
35
1,090
90
so i just openned msi afterburner to check the tem and the first think i noticed without even running a game with is it that my memory clock speed is 50% less than what is advertised on the manufacturer box and software
http://fr.tinypic.com/r/2aane4h/9
edit : msi afterburner says 5000 mem clocks while my aorus engine says 10 000
That is correct as its DDR memory, dual data rate. You would multiply that number by 2.

Go into your BIOS and make sure you have PBO and XFR enabled. These settings are usually found under the 'CPU' tab.
 
Apr 17, 2019
10
0
10
0
That is correct as its DDR memory, dual data rate. You would multiply that number by 2.

Go into your BIOS and make sure you have PBO and XFR enabled. These settings are usually found under the 'CPU' tab.
so yeah i checked on my bios and it was on auto so i enabled it but there is no change for fps
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS