My PC network is extremely slow!

Noken

Distinguished
Aug 24, 2011
9
0
18,510
Hey community,

Okay, I currently have 2 laptops and 1 custom built PC connected to the same router. The laptops are both wireless and my PC is connected by an Ethernet cable. But, for the past 3 months or so my PC constantly keeps disconnecting and running very, very slow if I'm browsing the internet or download YouTube videos. It's ADSL2+ and usually performs very quickly. But, at most stages it runs very slow and it only seems to be occurring on my PC not the laptops.

I've done a lot to try and fix this and looked on forums and such to find a fix but nothing seems to be working. I've restarted the router, bought a new Ethernet cable, restored my PC etc..

I was thinking of giving my ISP a call and seeing what the problem is, but what would I say to them aha?

Thanks for reading and please respond!
- Matt
 

Simo606

Honorable
May 11, 2012
292
0
10,860
Since your laptops work fine I am pretty certain the problem is isolated on your end or else your laptops internet would be slow also. Plus also your three private IP addresses get their IP addresses changed to your local address via NAT (network address translation) on the way out to the internet from your router so your ISP would only see 1 IP address and cannot selectively make 1 PC slower than the others.

So I think I can narrow the problem down to the link from your router to your PC. Including router configurations and/or PC configurations for that link.

That's all the advice I can offer without actually seeing your PC.

 

Noken

Distinguished
Aug 24, 2011
9
0
18,510
Hey guys,

Please help me out on this problem. Firstly, I have a PC and two laptops. And, my laptop speed on internet tests is running at 6.10 Mbps. While, my fast, gaming PC is only getting speed results of not a 1 Mbps. My laptops are both wireless and my PC is wired with an Ethernet cable.

I've tried many things to fix this. I've restored my PC, ran anti-virus, called my ISP and changed Ethernet ports. Please help me, I find it extremely difficult to browse the internet and play games like Battlefield 3.

Here are my PC specifications.

- GTX 580
- i5 2500k @4Ghz
- 8Gig RAM

Please, please, please help me! I don't know what else to do!

Thanks,
Matt Parker!
 

Noken

Distinguished
Aug 24, 2011
9
0
18,510
Hey guys,

My internet on my PC is extremely slow compared to my 2 wireless laptops. Take in mind that my PC has a wired Ethernet connection which is connected to a Netgear router which is, reasonably new. My internet speed is suppose to be at 6Mbps which it is on my laptops. But, on my PC it is constantly not even on 2Mbps. Which makes it extremely difficult for me to browse the internet and play BF3. My PC is an up to date gaming PC with an i5 2500k and 8Gig of RAM.

At one stage earlier on today, I did another test on my PC as soon as I got on and the results were at 6.55Mbps for about 5 minutes until my internet dropped out and I had to restart the internet to get it working again. When it came back online, my PC went back to 1.50Mbps which is annoying as hell!

I've tried, running virus scans, registry cleaners and I re-installed Windows 7 64 bit a couple of days back.

Please, please help and respond as I don't have a clue of what to do about it :( .

Thanks,
Matt!
 

Noken

Distinguished
Aug 24, 2011
9
0
18,510


I have a ASUS P8P67-M Pro. Thanks for you guys replying by the way.
 

jbseven

Distinguished
Dec 2, 2011
646
0
19,160
1. check for viruses/trojans on your pc. a variety of trojans cause the symptoms ur describing.
2. update lan drivers.
3. replace ethernet cable from pc to router.

This might seem obvious but if ur pc is trojan free, make sure you're running the speed test when absolutely nothing else is using the internet. that means ur laptops should not be using the internet at the same time. that means you should ake sure youtube isnt buffering or that ur not using utorrent in the background during the speed test.

Good luck