Question My PC randomly stops outputting any kind of signal

Sep 14, 2022
4
0
20
0
Please keep it to 1 thread
My PC will randomly stop outputting video, audio, and peripheral signals but the system continues to run. All fans continue to spin and all motherboard LEDs continue to light up. I am forced to hold the power button to restart it as I am left without any way to interact with the system. When I power it back on it springs back to life and I simply have to hope that it does not occur during anything important.

Specs:
Mobo: gigabyte ds3h v2 rev.1 (f63)
Psu: Antec Neo Eco Gold Lable 700w (NE700G ZEN)
Gpu: msi ventus 2x rtx 3060ti
Cpu: amd ryzen 5 2600
Ram: 2 x 8gb corsair vengeance 3000mhz ddr4
Boot drive: 500gb sata ssd
Os: windows 10 home
 
Last edited:
Sep 14, 2022
4
0
20
0
My PC will randomly stop outputting video, audio, and peripheral signals but the system continues to run. All fans continue to spin and all motherboard LEDs continue to light up. I am forced to hold the power button to restart it as I am left without any way to interact with the system. When I power it back on it springs back to life and I simply have to hope that it does not occur during anything important.

Specs:
Mobo: gigabyte ds3h v2 rev.1 (f63)
Psu: Antec Neo Eco Gold Lable 700w (NE700G ZEN)
Gpu: msi ventus 2x rtx 3060ti
Cpu: amd ryzen 5 2600
Ram: 2 x 8gb corsair vengeance 3000mhz ddr4
Boot drive: 500gb sata ssd
Os: windows 10 home
 
Sep 14, 2022
4
0
20
0
Specs:
Mobo: gigabyte ds3h v2 rev.1 (f63)
Psu: Antec Neo Eco Gold Lable 700w (NE700G ZEN)
Gpu: msi ventus 2x rtx 3060ti
Cpu: amd ryzen 5 2600
Ram: 2 x 8gb corsair vengeance 3000mhz ddr4
Boot drive: 500gb sata ssd
Os: windows 10 home
 
Sep 14, 2022
4
0
20
0
Please don't spam the forum, keep it to 1 thread
My PC will randomly stop outputting video, audio, and peripheral signals but the system continues to run. All fans continue to spin and all motherboard LEDs continue to light up. I am forced to hold the power button to restart it as I am left without any way to interact with the system. When I power it back on it springs back to life and I simply have to hope that it does not occur during anything important.

Specs:
Mobo: gigabyte ds3h v2 rev.1 (f63)
Psu: Antec Neo Eco Gold Lable 700w (NE700G ZEN)
Gpu: msi ventus 2x rtx 3060ti
Cpu: amd ryzen 5 2600
Ram: 2 x 8gb corsair vengeance 3000mhz ddr4
Boot drive: 500gb sata ssd
OS: Windows 10 Home
 

ASK THE COMMUNITY

TRENDING THREADS