[SOLVED] My PC reboots itself after upgrading to Samsung SSD 860 evo and Windows 10

Apr 22, 2019
5
0
10
0
My PC reboots itself multiple times after doing some heavy load task.. such as playing games, etc. my rig is old and im just slowly upgrading it..

My old specs were
Windows 8.1
Intel Pentium 4400
Ram 4GB
Asus H110-D motherboard
No Video card..
500GB hard drive..
(A potato Computer) but it is perfectly fine.. i can play starcraft 2 with medium settings with no problems.. and company of heroes with medium to high settings with good fps.. but when i bought a samsung SSD 860 evo and fresh install windows 10. at first it is perfect fine but after a few days problems started to show up... i cant even play starcraft2 without it crashing with BSOD and cant install games because of the unarc.dll/isdone.dll error.. and company of heroes crashes on start and my cpu and memory usage is high when i open games and sometimes it automatically restarts itself after a few minutes.. the bios and drivers are up to date.. i dont know whats wrong...maybe the PSU? because im using an old TRENDSONIC LC-8600BTX 600W PSU... what should i do?
 
Apr 22, 2019
5
0
10
0
My PC reboots itself multiple times after doing some heavy load task.. such as playing games, etc. my rig is old and im just slowly upgrading it..

My old specs were Windows 8.1 Intel Pentium 4400 Ram 4GB Asus H110-D motherboard No Video card.. 500GB hard drive.. (A potato Computer) but it is perfectly fine.. i can play starcraft 2 with medium settings with no problems.. and company of heroes with medium to high settings with good fps.. but when i bought a samsung SSD 860 evo and fresh install windows 10. at first it is perfect fine but after a few days problems started to show up... i cant even play starcraft2 without it crashing with BSOD and cant install games because of the unarc.dll/isdone.dll error.. and company of heroes crashes on start and my cpu and memory usage is high when i open games and sometimes it automatically restarts itself after a few minutes.. the bios and drivers are up to date.. i dont know whats wrong...maybe the PSU? because im using an old TRENDSONIC LC-8600BTX 600W PSU... what should i do?
 
i dont know whats wrong...maybe the PSU? because im using an old TRENDSONIC LC-8600BTX 600W PSU.
I think you might have answered your own question. I would definitely look into replacing that PSU model. Never heard of this brand before though. Might be some generic low quality PSU brand. So, you don't have any GPU installed on your PC ? A system reboot might be a sign of a failing PSU.

What are your new PC specs ?
 

Quarkzquarkz

Honorable
Sep 18, 2013
439
18
10,965
69
Never ever go cheap on PSU. You want a good name braned one with certified raitings to ensure voltage protection to your sensitive pc components. I never even heard of trendsonic and I assume immediately that power supply is no good. Good luck!
 
Reactions: BlazeJohnPyro
Apr 22, 2019
5
0
10
0
I think you might have answered your own question. I would definitely look into replacing that PSU model. Never heard of this brand before though. Might be some generic low quality PSU brand. So, you don't have any GPU installed on your PC ? A system reboot might be a sign of a failing PSU.

What are your new PC specs ?

I dont have yet any new specs... still upgrading my pc piece by piece the Samsung SSD is the new upgrade i recently bought. pc parts here in the Philippines is pretty damn expensive... as of the moment its all i have... NO GPU... just plain old potato PC...
 
Apr 22, 2019
5
0
10
0
Never ever go cheap on PSU. You want a good name braned one with certified raitings to ensure voltage protection to your sensitive pc components. I never even heard of trendsonic and I assume immediately that power supply is no good. Good luck!
Thank you I finally confirmed its my PSU it finally gave up on my hardrive.. and now only my SSD is running... hahaha.... and yes it is cheap... planning on buying corsair 650watts... soon
 

ASK THE COMMUNITY