Question My PC turned off suddenly, help!

Sep 7, 2019
23
0
10
0
My pc turned off suddenly and didnt want to turn on immediatley, it turned on after 2 mins.

PC Spec:
Ryzen 3 2200g no OC
8gb ddr4-2400
RX 480 8gb no OC (connected via 2xmolex to 8 pin)
500w no certificate, model: MS-500
 

JadeHarley

Commendable
May 11, 2018
96
8
1,545
2
yeah as Calvin said, probably Power Supply wanna die, cause it's super bad quality, buy an FSP 500, it's gonna be number 1 choice for budget build
 
Sep 7, 2019
23
0
10
0
Here is the thing, I have my GPU connected trough 2 molex cables on 6pin than trough connector 6pin to 8pin. I was gaming casually, playing gta 5. when I entered pubg yellow cable was melting. That yellow cable was on molex to 6pin connector. After that when I entered pubg later that time monitor displayed something like rice (black and white) for 5 sec and goes black!

After that I switched PSU, new PSU is CODEGEN 300XA (500W) and it displayed the same thing. But everything is normal with the gpu when not gaming, oh yes... GPU is RX 480 8gb Sapphire Nitro... Only that yellow cable is heating abnormally when gaming.

I reinstalled drivers and entered again in pubg it didnt displayed that rice thing and black screen but yellow cable was heating again. It started to melt down plastic connector. I think it is because bad PSU or that cables. But only yellow cable on Molex to 6pin connector is heating, yellow cable from psu is fine and cold. It may be some kind of bad connection or not powerfull PSU. Please help me!

PC SPECS:
Ryzen 3 2200g
8GB ram ddr4 2400
asus prime a320m-k
RX 480 8GB Sapphire Nitro
problem happened on first psu MS-500 (500W) and happened again same thing on CODEGEN 300XA (500w)
 
Sep 7, 2019
23
0
10
0
I know, its some bad psu 100%, cuz it only has 2 molex, 2 sata and other for cpu and mobo. It is same as that MS-500
 
Here is the thing, I have my GPU connected trough 2 molex cables on 6pin than trough connector 6pin to 8pin. I was gaming casually, playing gta 5. when I entered pubg yellow cable was melting. That yellow cable was on molex to 6pin connector. After that when I entered pubg later that time monitor displayed something like rice (black and white) for 5 sec and goes black!

After that I switched PSU, new PSU is CODEGEN 300XA (500W) and it displayed the same thing. But everything is normal with the gpu when not gaming, oh yes... GPU is RX 480 8gb Sapphire Nitro... Only that yellow cable is heating abnormally when gaming.

I reinstalled drivers and entered again in pubg it didnt displayed that rice thing and black screen but yellow cable was heating again. It started to melt down plastic connector. I think it is because bad PSU or that cables. But only yellow cable on Molex to 6pin connector is heating, yellow cable from psu is fine and cold. It may be some kind of bad connection or not powerfull PSU. Please help me!

PC SPECS:
Ryzen 3 2200g
8GB ram ddr4 2400
asus prime a320m-k
RX 480 8GB Sapphire Nitro
problem happened on first psu MS-500 (500W) and happened again same thing on CODEGEN 300XA (500w)
That PSU is a piece of garbage. It's definitely not 500W. It only handles 18A @12V. Making it a 216W PSU. It's just one of those deals where it supposedly handles a ton of amps on 3.3V and 5V. Which is useless as nearly all power draw in a PC is 12V.

Looking at the cables. They look scrawny. Probably 20 AWG or higher. Way too thin for that GPU. It simply isn't designed for your computer.

Get something like a Corsair RMx, CMx, TXM; EVGA G2, G3, G1+, G5; Seasonic Focus Gold, Focus Gold Plus, GM, GX.

Even some cheap range EVGA BQ/BR would be a huge improvement. Dare I say even a Raidmax.:eek:. Seriously dont get a Raidmax.
 

ASK THE COMMUNITY

TRENDING THREADS