Question My PC turns on with windows running but no display signal ?

May 22, 2020
3
0
10
0
I built my first pc 1 month ago. It has:

Gigabyte b450m ds3h
ryzen 3 3100
palit rtx 2060 stormx
16 gb g.skill aegis 3000 mhz

My pc worked flawlessly untill today. When i turned it on the pc booted up to windows, i heard the windows start chime, but there was no display signal on both of my monitors. I tried all the ports, all my cables and i even dug up one of my old monitors but none of them worked. i reseated my gpu and my ram but nothing changed. i unplugged my peripherals and nothing. mind you its still booting up to windows but no display signal. i managed to enter my password by memory and when i entered windows i think google strated itself and i heard a video playing, so i assume my pc is working. i took out my cmos battery and put it back in but nothing... i have not overclocked anything or changed anything in my pc or on windows and only just today i stopped receiving video signal.

I have checked all my connections and everything is fully seated and conected. is it to do with my gpu?
 
May 22, 2020
3
0
10
0
Yeah I selected HDMI imput but nothing. I tested it even on my TV and also I tried the DVI and DisplayPort to connect to my monitors but no sign of a signal, even though I can still hear The windows boot sound. Monday I'll be sending my GPU to warranty to see what's gone bad with it.
 

Karadjgne

Titan
Ambassador
It's unfortunate, but failures happen. If you think of the Billions of transistors, capacitors, resistors etc and the kazillions of solder joints on just gpus alone every year, it's impossible not to have just one failure, somewhere, in something. One tiny diode failure and the whole gpu is kaput.

Good luck with the repair/replacement.
 

ASK THE COMMUNITY