Question My pc used to run games at high settings and around 60-70 frames and now im lucking if i can stay above 20. Why is this?

May 15, 2022
2
0
10
0
Games I used to run just fine now struggle hard and barely run.

I used to run games at high at 70 frames but now no matter what I run the games on I get an average of 15 frames. I've updated drivers for my graphics card, Uninstalled a bunch of stuff to make sure there's plenty of space on my memory, and make sure nothing else is taking up usage with task manager.

My cpu usage is always at like 99% and I think I'd need to update drivers for my processor but AMD doesn't let me, my processor isn't an option and auto detect says I don't have any amd items in my computer (I only have an amd processor it's a FTX 4300 Quad Core Processor

Any help with this would he appreciated.
 
May 15, 2022
2
0
10
0
Games I used to run just fine now struggle hard and barely run.

I used to run games at high at 70 frames but now no matter what I run the games on I get an average of 15 frames. I've updated drivers for my graphics card, Uninstalled a bunch of stuff to make sure there's plenty of space on my memory, and make sure nothing else is taking up usage with task manager.

My cpu usage is always at like 99% and I think I'd need to update drivers for my processor but AMD doesn't let me, my processor isn't an option and auto detect says I don't have any amd items in my computer (I only have an amd processor it's a FTX 4300 Quad Core Processor

Any help with this would he appreciated.
 
Games I used to run just fine now struggle hard and barely run.

I used to run games at high at 70 frames but now no matter what I run the games on I get an average of 15 frames. I've updated drivers for my graphics card, Uninstalled a bunch of stuff to make sure there's plenty of space on my memory, and make sure nothing else is taking up usage with task manager.

My cpu usage is always at like 99% and I think I'd need to update drivers for my processor but AMD doesn't let me, my processor isn't an option and auto detect says I don't have any amd items in my computer (I only have an amd processor it's a FTX 4300 Quad Core Processor

Any help with this would he appreciated.
What changed?
No such thing as a ftx 4300.

Download this.
UBM

Reboot and wait a few mins then run UBM with the browser closed.
Post a LINK to the results page.
 

ASK THE COMMUNITY