• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Meet Stan Dmitriev of SurrogateTV on the Pi Cast TODAY! The show is live August 11th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Professional PC modder Mike Petereyns joins Scharon on the Tom's Hardware Show live on Thursday, August 13th at 3:00 pm ET (8:00 PM BST). Click here!

[SOLVED] My PC won't boot anymore

Sep 3, 2019
5
0
10
1
Hello, I've had this issue for quite a while, my computer wouldn't boot, I read the thread about the boot problems and nothing that was shown there worked. Turned the PC on, all lights light up, fans are on, the mouse's light turns on but not the keyboard's, the monitor remains in sleep mode. What i tried doing was shutting on and off and maintaining the power button to get rid of all the extra power every time until it worked, could sometimes take up to an hour to turn it on so i'd just put the pc into sleep mode instead of shutting it off - stayed like this for about 2 months and it never shut off on its own. When I did succeed in turning it on back then it'd tell me that the current bios settings failed to boot the computer and that the default settings were used instead. I never thought of actually put the default setting back because i actually didn't really pay attention, i tried removing the cmos coin to reset the settings but nothing happened. The PC worked really fine otherwise, I could play and draw on it and just do whatever without a single problem. I shut it off last weekend because i wasn't home for a few days, came back and turning it on was impossible. My guess is that the cmos battery is dead and can't save the settings? I haven't tried buying a new one but I honestly barely know anything about computers so i'd like to get some advice before spending money into anything.
I don't have the full specs now but I can give them tomorrow, here's what I know for now :
MSI Z77A-G45
NVIDIA GeForce GTX 670
Windows 10 64bits
 

nostall

Splendid
Moderator
Yes please post the specifications so we can have a better idea of where potential problems might be.
This sounds like it could be a power supply problem. If you have another Known, Good, Working power supply available try hooking it up to your PC and see if that doesn't solve the problem.
Looking forward to seeing the rest of the specs.
 
Sep 3, 2019
5
0
10
1
MSI Z77A-G45
NVIDIA GeForce GTX 670
Antec HCG - 620
HD Interno Seagate desktop hdd 1000gb
G Skill Sniper 4GB 1866 mhz
Corsair Vengeance 4 GB 1600 mhz

The two ram sticks are different ones because one wasn't working anymore so i just replaced it but i don't know if it can be the source of a problem
I have another power supply Antec EA-500D (500w) and i'm guessing that won't be enough? I don't know how much my pc needs, it was given to me already built. Haven't had time to look at the cpu because it was hidden behind a fan, but i can look into it once I'm home again. If there's anything missing please tell me and i'll also take a look at it-
Thank you!
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS