• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Meet Stan Dmitriev of SurrogateTV on the Pi Cast TODAY! The show is live August 11th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Professional PC modder Mike Petereyns joins Scharon on the Tom's Hardware Show live on Thursday, August 13th at 3:00 pm ET (8:00 PM BST). Click here!

Question My PC won't POST after I built it. MOBO RGB comes on but no power elsewhere.

Jun 1, 2020
3
0
10
0
I just built (well tried) building my first PC. After plugging everything in and making sure all was right, I went to turn it on aaaannnndd... the RGB lights came on my MOBO and when I hit the power button on my case, nothing.

I have tried troubleshooting a few things but am at a loss.

I made sure the front panel pins were connected properly.
I re-seated my CPU.
I did the paper-clip method of testing my PSU and this is the one that ended up being kind of weird. I hooked up the PSU to my HDD (I have no fans other than chassis and CPU) and when I did the paper clip test my HDD booted up and was operating. It does NOT operate when everything else is hooked up. Could the problem still lie with my PSU?
I have also slotted my RAM into all the slots with just one, and still nothing. I have not tried using different RAM as I do not have any other sticks.
I have also double, triple, and quadruple checked all the connectors were connected properly ;)

My build is
MOBO - ASRock B450M Steel Legend
CPU - Ryzen 5 3600 AM4
GPU - MSI GEFORCE GTX 1660 super
PSU - Corsair 550w bronze+
Memory - Samsung 860 EVO 250g sata m.2
A 1TB HDD
RAM - G.SKill Ripjaws 2x8gb

Any advice would be greatly appreciated! Thank you!
 

R_1

Illustrious
Ambassador
That is why I capitalized the word IF
the only boards I know are out of the box ready for the 3 series are the 5xx series boards and the MSI boards with the MAX moniker.
MSI signifies the ready boards with the word MAX in the model.
IDK how long that board was on the shelf.
 
Jun 1, 2020
3
0
10
0
That is why I capitalized the word IF
the only boards I know are out of the box ready for the 3 series are the 5xx series boards and the MSI boards with the MAX moniker.
MSI signifies the ready boards with the word MAX in the model.
IDK how long that board was on the shelf.
Ok thank you!
According to https://www.asrock.com/support/cpu.asp?s=AM4&u=598 , if I'm reading the chart correctly, it says that the MOBO is p2.10

So I'm not sure if it is indeed the BIOS causing the issues.
 

R_1

Illustrious
Ambassador

the BIOS issue was the elephant in the room. the most obvious issue to clear this troublshooting checklist can help. go down the list every one.
 

ASK THE COMMUNITY

TRENDING THREADS