My pc won't turn on after installing a new motherboard, CPU and cooler

jagerpeever03

Prominent
Dec 25, 2017
1
0
510
0
So I got a new CPU: I7 8700k, motherboard: Asus rog strix z370f, cooler: nzxt Kraken x62. I finished installing everything and I try to press the power button and nothing happens, I'm getting really mad can someone please help? the only thing that happens is that my motherboard leds are on
 

Vic 40

Polypheme
Herald
Oct 22, 2013
14,949
1
63,315
2,313
Double check connectors. Put ram in slots 2+4 from the cpu out and maybe even reseat gpu.
 

Dashman9000

Distinguished
May 16, 2009
189
1
18,765
38
It is incredibility easy to miss a connection in a new build. Please double check all motherboard connections from the motherboard documentation. Make double sure all of your case front panel connections are correct going into the motherboard, I made this mistake before. Go back through all connections and take your time referring to the MB docs.
 

waffleisback

Commendable
Feb 13, 2017
158
0
1,710
5


Yes that is most likely it, especially if you are using a new motherboard. Also I've heard that sometime if you get a new motherboard your system wont like to boot into Windows though I'm not 100%. If you can turn on your computer open your BIOS or UEFI and check the boot order.
 

arvram8

Prominent
Dec 2, 2017
26
0
540
1
Your CPU is not compatible with your motherboard. Even though it fits perfectly, the internals of the CPU are different and cannot be recognized by the BIOS. You have to buy a 7th or 6th gen CPU.
Update:nvm, it is compatible
 

Vic 40

Polypheme
Herald
Oct 22, 2013
14,949
1
63,315
2,313
All nice,but this is for here a pretty old thread and the OP hasn't even bothered to respond so leave it alone untill then?