Question My PC won't turn on after upgrading from Ryzen 1500x to 3700x

Garrethban

Reputable
May 31, 2017
10
0
4,510
0
I updated the Bios to the relevant one's and installed the new CPU but when I hit the power button nothing happens.

I have reinstalled the 1500x which works fine and made sure the bios was updated properly. Chipsets also installed correctly.

I have also tried resetting CMOS.

Mobo - Gigabyte gaming B350m (matx version)

GPU - GTX 1070

Ram -4x4gb ballistix 2100mhz

PSU- Corsair 650 m

Do I need new MOBO or PSU even though Gigabyte state 3000 series should work with B350m after BIOS

One thing I did note however was the EC FW update they recommend did nothing other than to add a text file to the folder that just said "00000"

Edit: I've also checked the CPU and there's no bent pins and it's brand new
 
I cannot recall, but does the 3700X even work with RAM at 2100? I though the newer chips went up to minimum of 2400?
I may well be wrong.

The only other straw I can grasp right this moment is to suggest using a lower power GPU and see if it will boot?

What is EC FW update?
 

Garrethban

Reputable
May 31, 2017
10
0
4,510
0
I cannot recall, but does the 3700X even work with RAM at 2100? I though the newer chips went up to minimum of 2400?
I may well be wrong.

The only other straw I can grasp right this moment is to suggest using a lower power GPU and see if it will boot?

What is EC FW update?

You could be right with the ram, I don't have a lower powered GPU to hand unfortunately

EC FW is some strange update they recommend you do before updating from one BIOS to another but isn't a necessity as far as I'm aware
 
Which BIOS version
You could be right with the ram, I don't have a lower powered GPU to hand unfortunately

EC FW is some strange update they recommend you do before updating from one BIOS to another but isn't a necessity as far as I'm aware
When updating to the certain BIOS versions, EC FW is recommended to avoid issues with some RAM when 4 modules are installed.

Which BIOS version do you see in the BIOS?
Does the 3700x works with only two RAM modules?
 

Garrethban

Reputable
May 31, 2017
10
0
4,510
0
Which BIOS version

When updating to the certain BIOS versions, EC FW is recommended to avoid issues with some RAM when 4 modules are installed.

Which BIOS version do you see in the BIOS?
Does the 3700x works with only two RAM modules?
No it doesn't turn on with 1,2,3 or 4 Ram sticks installed.

The EC FW update does absolutely nothing when I try to install it before F40. It just creates a text doc that just says "00000"

Right now Bios is saying F40

When I switch back to the 1500x the pc turns on but then quickly restarts itself (before coming up with the option to go into bios) and then boots back up normally.

When I load the bios back up again with 1500x it says the message I posted above
 

Garrethban

Reputable
May 31, 2017
10
0
4,510
0
Can you confirm that this CPU is working any other way?
Is it new or purchased in such as way as to be able to return it?
Brand new and I can return it but there doesn't seem to be anything wrong with it, pins all seem fine.

I've ordered a newer model board to see if that's the issue as the guys on the gigabyte boards seem to think the mobo isn't holding the bios updates for some reason
 
Brand new and I can return it but there doesn't seem to be anything wrong with it, pins all seem fine.

I've ordered a newer model board to see if that's the issue as the guys on the gigabyte boards seem to think the mobo isn't holding the bios updates for some reason
If it reports to you that it's on F40 it's already installed.
Things do come BOB, thankfully not very often.
 
No it doesn't turn on with 1,2,3 or 4 Ram sticks installed.

The EC FW update does absolutely nothing when I try to install it before F40. It just creates a text doc that just says "00000"

Right now Bios is saying F40

When I switch back to the 1500x the pc turns on but then quickly restarts itself (before coming up with the option to go into bios) and then boots back up normally.

When I load the bios back up again with 1500x it says the message I posted above
The only thing you needed to do is update the board to BIOS version F31 before updating to F40 if you were using the Q-Flash Utility.
Try updating the BIOS to another version...like F50a or 50d
 

ASK THE COMMUNITY

TRENDING THREADS