[SOLVED] My PC won't turn on with the GPU plugged in!

Feb 1, 2020
2
0
10
0
Hey guys! First post here. So it's my brother's computer. He said he was in the middle of using it when suddenly it shut off. It' wont turn back on now. Here's some test I did!

-Took out the gpu and the system booted up
-Put in my own gpu and the system booted up
-Put in my brother's gpu into my stystem and it wouldn't boot up

When I try booting up his computer with his gpu in it no fans spin but some red lights do flash quickly. The light above where you put the psu cables into the gpu flashes red. Any help is appreciated, thanks!

Brother's Specs: https://pcpartpicker.com/user/DoZeJJ/saved/yv8FGX
My Specs: https://pcpartpicker.com/user/DoZeJJ/saved/TRDcqss
 

bignastyid

Titan
Moderator
I highly doubt that. He knows nothing about computers so i doubt he would mess with any settings like that. If he unplugged his mouse he would come to me asking why isn't it working. I genuinely think it's a dead card but i want to try other things before I know for sure;
You've done about all you can do to isolate it to a problem with the card. Time to RMA it.
 
Feb 1, 2020
2
0
10
0
Unless he was messing with the vbios it's likely a bad GPU.
I highly doubt that. He knows nothing about computers so i doubt he would mess with any settings like that. If he unplugged his mouse he would come to me asking why isn't it working. I genuinely think it's a dead card but i want to try other things before I know for sure;
 

bignastyid

Titan
Moderator
I highly doubt that. He knows nothing about computers so i doubt he would mess with any settings like that. If he unplugged his mouse he would come to me asking why isn't it working. I genuinely think it's a dead card but i want to try other things before I know for sure;
You've done about all you can do to isolate it to a problem with the card. Time to RMA it.
 

ASK THE COMMUNITY

TRENDING THREADS