Question My PS4 Pro won't turn on, power button not working, but eject button works ?

Dec 2, 2021
1
0
10
0
I didnt turn on my ps4 pro for 2 weeks, today when i turned it on it gave up on me.

the behaviour is as follows,

when I switch on power from wall socket and try turn it on form the 1st time it gave me 3 beeps and turned off, when i tried to tun it on it gave a beep and went into safe mode. which ever option i try in safe mode it boots back to safe mode(loop). Tried update with pendrive and also full reinstall as well.
i read somewhere that power input issues, so I tried unplugging and put the adaptor in different socket. the things went further bad.
now i cant turn on my ps4 pro at all, power button stopped responding, i can’t turn on using my controller (tried both wired and wireless).
I was using a ssd, so I tried replacing with original HDD as well. same behaviour.

I thought my ps is dead, then suddenly i clicked on eject button and it gave 2 beeps saying no disk in bay. so i tried inserting a disk, and my ps4 pro started to boot and again it went into safe mode loop, like earlier.
So I am not sure what is the problem is, is it anything i can fix or hardware issue.
Any helps on how to proceed further is highly appreciated .
 

ASK THE COMMUNITY

TRENDING THREADS