Question My RAM is working but every app on my computer crashes

May 14, 2020
2
0
10
0
About 2-3 weeks ago, I ordered new RAM for my PC (Specifically G.Skill Aegis 16GB (2 x 8GB) 288-Pin DDR4 SDRAM DDR4 3000) I made sure it was compatible with my motherboard (MSI B350M Gaming Pro) before I bought it off of Newegg. When it arrived, I shut off my computer, grounded myself, and installed the RAM. When I turned my computer on after installing my new RAM, it restarted 3 times before it actually booted up (I'm not sure if that's normal but I'm throwing this in here just in case its not). When it finally booted up, I checked my task manager to see if it was installed properly and was reading it all, but when I looked at my memory it said I had 16GB, but was only using 8GB and the other 8GB was "Reserved for Hardware". I did every trick in the book to try and fix that, and followed half a dozen YouTube tutorials to try and fix it, but to no avail. I then shut my computer back off and swapped the RAM sticks around, to see if that would do anything (I only have 2 RAM slots, not 4). But, since one of the sticks was faulty, the RAM kept bouncing power back and fourth and fried my motherboard. So, I sent my board back to MSI for them to either fix or replace (which they replaced it with the same one) and I also sent back my faulty RAM for a replacement. I just got my motherboard 2 days ago, and when I reinstalled my old RAM back into it, it was reading both sticks fine, but now every time I open up any app on my PC, it crashes. I open Chrome, and if I open more than 3 tabs, it gives me an error message saying I don't have enough memory or crashes all together making me have to restart my PC. I open Discord along with 1 Chrome tab and both applications crash, and I have to restart my PC. When I try and launch Minecraft, it launches, and then instantly takes me back to the launcher, saying that I have "...insufficient memory for the Java Runtime Environment to continue" I have tried everything to try and fix this including updating my BIOS but again, to no avail. My new replacement RAM is supposed to be coming tomorrow (May 15th) and I'm hoping that maybe the new RAM will fix whatever problem I'm having, but I'm not sure. I'm hoping that someone would be able to help me through this problem because I'm getting really frustrated about this
 

ASK THE COMMUNITY

TRENDING THREADS