[SOLVED] My RAM isn't running at full speed

Matthew11511

Commendable
Jun 2, 2019
17
0
1,510
0
I have a B450-F motherboard. I just recently built my pc (less than a year old) I first had 2x8(16GB) at 3200Mhz and I upgraded to 2x16 (32GB) at 3200Mhz. With the 16 GBs I was able to run at 3200 but now with the new sticks, they're not running at spec speed. In bios they say they are but in task manager, speccy, and ryzen master all say its running at 1600Mhz. The timing according to speccy and ryzen master is different from the bios also? Not sure how to fix. Also, task manager, speccy and ryzen master used to say running at 3200 with the old sticks.
 
I have a B450-F motherboard. I just recently built my pc (less than a year old) I first had 2x8(16GB) at 3200Mhz and I upgraded to 2x16 (32GB) at 3200Mhz. With the 16 GBs I was able to run at 3200 but now with the new sticks, they're not running at spec speed. In bios they say they are but in task manager, speccy, and ryzen master all say its running at 1600Mhz. The timing according to speccy and ryzen master is different from the bios also? Not sure how to fix. Also, task manager, speccy and ryzen master used to say running at 3200 with the old sticks.
It's DDR (Double Data Rate) so 1600x2=3200MHz.
Some programs show base speed and others full speed.
 
I have a B450-F motherboard. I just recently built my pc (less than a year old) I first had 2x8(16GB) at 3200Mhz and I upgraded to 2x16 (32GB) at 3200Mhz. With the 16 GBs I was able to run at 3200 but now with the new sticks, they're not running at spec speed. In bios they say they are but in task manager, speccy, and ryzen master all say its running at 1600Mhz. The timing according to speccy and ryzen master is different from the bios also? Not sure how to fix. Also, task manager, speccy and ryzen master used to say running at 3200 with the old sticks.
It's DDR (Double Data Rate) so 1600x2=3200MHz.
Some programs show base speed and others full speed.
 

ASK THE COMMUNITY