Question My RTX 2070 fans are spinning to 100% then slowly stopping. No picture on displays. Any ideas?

Apr 22, 2020
1
0
10
0
I just upgraded my PC to a Ryzen 3600X, MSI Tomahawk B450 PRO and an RTX 2070. Everything went smoothly except I needed an 8 and a 6 pin PCIE cable (my GTX 1060 didn't need the 8 pin). So i continued playing with just the 1060 until the cable arrived. Installed the 2070 and the PC wouldn't power on. I disconnected the GPU and used a donor PSU from work only plugging in the CPU and Mobo 24 pin and it powered up. Ordered a new Corsair RM650 and got it all set up today except one of my SATA 3-Way power cables was stopping my PC from powering up so I swapped it for a new one that came with my PSU. The system now powers up but the RTX 2070 spins its fans to 100% then they slowly stop until they stopped moving. I have tried using HDMI and Displayport to both of my monitors but nothing displays. Also, my mouse and keyboard don't light up.

I have a few ideas but I need other people's inputs on what might be going on:

  • My first idea is that the GPU is just dead and I will have to RMA.
  • My second idea is that maybe the SSD or the HDD is dead since it was the SATA power cable preventing me from booting but I assumed i'd still be able to access the BIOS anyway.
I don't know why my keyboard and mouse aren't lighting up either but sometimes I have to get past the BIOS before they do.
 

Vic 40

Titan
Ambassador
Ordered a new Corsair RM650 and got it all set up today except one of my SATA 3-Way power cables was stopping my PC from powering up so I swapped it for a new one that came with my PSU.
Sounds like you are swapping cables between psu's which is not what you want to do, only use the cables that came with the RM650 and hope nothing is damaged.
 

ASK THE COMMUNITY