[SOLVED] My Rx570 isn't detected at all what should i do ?

Nov 18, 2020
6
0
10
0
I have an Rx 570 8gb nitro+ and it doesn't display my screen is black but everything runs properly so i can't install the driver what should i do ? I used teamviwer to install the driver but the installer isn't detecting my gpu at all even in the device manager can't find my gpu
My gpu runs correctly I've tried it on my friend's PC I've tried another psu same problem
I'm running out of ideas please help !
Specs
Motherboad: Biostar h81mgv3 ( bios updated )
Psu :525w thermaltake
Cpu : intel i5-4440
Ram 8gb corsair 1600mhz
Screen: samsung syncmaster sa100 (vga)
Win 10 latest update
 

mdd1963

Polypheme
Might want to try remove power from PSU, pull CMOS battery from mainboard, hold down case PWR SW for 20 sec, reinsert battery, reapply power, retest...

(If using a modular PSU, and/or testing a different one, realize you can't mix modular cables between PSUs, which, if not heeded can be disastrous...and quite quickly...
 
Nov 18, 2020
6
0
10
0
Might want to try remove power from PSU, pull CMOS battery from mainboard, hold down case PWR SW for 20 sec, reinsert battery, reapply power, retest...

(If using a modular PSU, and/or testing a different one, realize you can't mix modular cables between PSUs, which, if not heeded can be disastrous...and quite quickly...
I did what you told me to do but nothing has changed and i'm not using a modular PSU
 
Nov 19, 2020
10
0
10
0
I did what you told me to do but nothing has changed and i'm not using a modular PSU
That happened to me about a year ago and i had a help with a friend of mine, basically you need another computer and like see your display on the other computer's monitor, i forgot what it's called
 
Nov 18, 2020
6
0
10
0
That happened to me about a year ago and i had a help with a friend of mine, basically you need another computer and like see your display on the other computer's monitor, i forgot what it's called
Teamviewer ? i already used it but still my PC isn't detecting my GPU at all it's so werid
 
Nov 18, 2020
6
0
10
0
If the GPU works in your friend's PC but not yours even after trying a different PSU and making sure everything is connected correctly, then maybe your PCIe x16 slot has died. You'd need to try a different GPU to confirm that.
Thanks i've changed my motherboard and now it's working
 

ASK THE COMMUNITY

TRENDING THREADS