My screen isnt displaying anything after i installed the amd software

Arcanekitten

Reputable
Sep 20, 2014
253
0
4,810
8
hi guys from tomshardware

i have build today my first PC where i am very proud of everything went great but when i just finished the catalyst amd software thing it asked me to reboot but that dint went great when it turn off there was no problem but when it booted up again i dint get any display.
de screen turns on for a moment it just says (because it is a tv monitor) PC --:-- and then a couple seconds later it turns off i hear on the background the windows sound when you just started up your pc and thats it i am stuck i restarted it a couple times but with no result i have done some things before on the pc before it happend like internet ,skype call and more.
also some of my USB ports do not work on the back and also before it happend only the display cable seems to work i have two VGA monitors one with also a hdmi input (the tv monitor)
here are my specs

windows 7 home premium 64 bit
fx 8350
hyper 412s
msi r9 290 twin frozr
asrock extreme 3 r 2.0
1 ssd 120 gb
1 hdd 500 gb which doesnt work (very WEIRD)
1 HHD 3 tb which does work just fine
2x2 ram 1333
1x4 ram 1333
cooler master (i believe) G750M
 

Arcanekitten

Reputable
Sep 20, 2014
253
0
4,810
8


yes i fixxed it

i switched out my vga cable with a hdmi cable
but sadly my other monitor doesnt work because its a vga input only

but still can you help me with this i have a problem that my usb 2.0 do not work my usb3.0 just work fine but my usb 2.0 and audio jack do not i dont know how to fix it i probably going to ask some guy i know but maybe you can help me
 

Darkbreeze

Titan
Moderator
As far as your second monitor go's, you need to right click on the desktop, select "resolution" and then select extend these displays in order to make the second monitor work. You should also be able to designate whether the VGA or HDMI monitors are primary or secondary. The HDMI may insist on being #1 though in some configurations.
 

Arcanekitten

Reputable
Sep 20, 2014
253
0
4,810
8


thats not the problem :the configuration
but it doesnt reconise it it just lights up like it would but with no display and then a second later it goes to sleep thats it i have my second monitor on a displayport to vga and the screen which works on hdmi
 

Darkbreeze

Titan
Moderator
Have you installed all the chipset and other hardware drivers from the motherboard manufacturers website for your model of board? Many times the windows native drivers are not sufficient. Go into control panel, device manager and see if there are any hardware components that are highlighted. If so, you probably need to install the appropriate drivers. If it's not a driver issue, then it's an issue with the motherboard itself.
 

Arcanekitten

Reputable
Sep 20, 2014
253
0
4,810
8


ok i will check that out also i still have the problem with my monitors :

thats not the problem :the configuration
but it doesnt reconise it it just lights up like it would but with no display and then a second later it goes to sleep thats it i have my second monitor on a displayport to vga and the screen which works on hdmi
 

Darkbreeze

Titan
Moderator
So you're saying you HAVE gone into the desktop display properties and enabled the second monitor to be a part of an extended display configuration? Because if you don't, it will do exactly as yours is doing and not receive any signal from the GPU. Other than that it should work. You may need to use a DVI to VGA adapter instead of using the displayport. I don't know why you would have to do that, but some GPUs are finicky. Might also just be a problem with the GPU itself or one of your adapters.
 

Arcanekitten

Reputable
Sep 20, 2014
253
0
4,810
8


well another problem i dont think its possible to have a dvi-D to vga because my video card only has 2 dvi-D ports 1 HDMI and 1 Displayport BTW the usb problem is solved there was a update for the drivers
 

Arcanekitten

Reputable
Sep 20, 2014
253
0
4,810
8
also my pc doesnt seem to find my third Harddrive i have 1 SDD that works and 1 HHD that works but the third doesnt work i have no i have no idea what i have done wrong
 

Arcanekitten

Reputable
Sep 20, 2014
253
0
4,810
8
alright after a close look at the problems i solved that my hdd wasnt linked to a number and my display to vga adapter dint work i dont know how it broke but hopefully a new one will help also thanks for the advice that you gave me i will reply to this if the new display port adapter works
 

ASK THE COMMUNITY

TRENDING THREADS