Question My sisters Brand New PC popped on the 2nd time booting and now wont turn on.

May 17, 2020
3
0
10
0
Hi, so my sister recently purchased all the necessary PC components and I helped her assemble it, I got it to POST and installed Windows. She tried to turn it on today and it turned on, made a popping sound and then shut off completely and is now unresponsive. All the other outlets in the room also stopped working after that too, no lingering smell or scorch marks.
Her build is
Ryzen 5 3600
RTX 2060 SUPER 8 GB
Corsair Vengeance 2.4 GHz
Evga N1-0750-L1 750W Power Supply
MSI B450M-A Pro MAX MOBO
500 samsung evo 860 SSD
Is it a faulty power supply? Did I install something incorrectly? Any thoughts would be greatly appreciated
 
Feb 29, 2020
207
25
120
3
If the other outlets are off it's the breaker, check that first.
If you already installed windows you installed everything correctly.
Capacitors tend to pop when they blow up but that's a total shot in the dark.
I don't suppose you have a multi meter? I would disconnect everything and start with the PSU and make sure it's outputting the proper voltage.
If there is no fried electronics smell you might have got lucky, but from here it sounds pretty bad.
 

COLGeek

Cybernaut
Moderator
Check the breaker and try resetting, first. Could just be one too many devices on that circuit. If not that...

I would suspect the PSU as well. A quick swap with a known, working one would help to isolate.

You should also double check for any shorts (like caused by extra stand-offs (mounting points) between the mobo and case, as well as any of the little fingers (for grounding) around ports that stick through the ATX I/O Panel (back of system).
 
May 17, 2020
3
0
10
0
If the other outlets are off it's the breaker, check that first.
If you already installed windows you installed everything correctly.
Capacitors tend to pop when they blow up but that's a total shot in the dark.
I don't suppose you have a multi meter? I would disconnect everything and start with the PSU and make sure it's outputting the proper voltage.
If there is no fried electronics smell you might have got lucky, but from here it sounds pretty bad.
She saleslady checked the breaker box and I already did unplug everything and was going to try test each individual part on my own PC for some damage control. Thank you tho Im hoping its just a faulty PSU that somehow committed toaster bath with no other repercussions.
 
May 17, 2020
3
0
10
0
Hi, so my sister recently purchased all the necessary PC components and I helped her assemble it, I got it to POST and installed Windows. She tried to turn it on today and it turned on, made a popping sound and then shut off completely and is now unresponsive. All the other outlets in the room also stopped working after that too, no lingering smell or scorch marks.
Her build is
Ryzen 5 3600
RTX 2060 SUPER 8 GB
Corsair Vengeance 2.4 GHz
Evga N1-0750-L1 750W Power Supply
MSI B450M-A Pro MAX MOBO
500 samsung evo 860 SSD
Is it a faulty power supply? Did I install something incorrectly? Any thoughts would be greatly appreciated
I also pulled out the power supply screen and there was a piece of silver metal and 2 green pieces of plastic material
 

ASK THE COMMUNITY